rmeike's Avatar


20 Feb, 2012 05:13 PM

GPG quit working in Apple Mail after I went to iCloud. I think the problem may be that Apple added "(iCloud)" to my account name in Apple Mail. I'm running 10.7. Is there way to fix this?

  1. Support Staff 1 Posted by Steve on 20 Feb, 2012 06:05 PM

    Steve's Avatar

    Hey Rusty,

    could you please try our latest bakery: GPGMail 2.0a33 - http://cl.ly/0O1x3f3P1J0l1k2O382u

    Also: already read our quickstart tutorial to get the right setup? http://support.gpgtools.org/kb/how-to/first-steps-where-do-i-start-...

  2. 2 Posted by rmeike on 20 Feb, 2012 06:19 PM

    rmeike's Avatar

    Thanks for the quick reply, Steve. I'm sorry, but I don't know what to do with a .mailbundle file.

    Also, I have read the tutorials previously in order to get everything set up correctly. Just to be clear, everything was working fine until I switched to iCloud.

    My account name in Mail was previously [email blocked]. It is now [email blocked] (iCloud). This does not correspond to anything in my GPG Keychain. Do you think that might be the problem?

    Thanks again.

  3. Support Staff 3 Posted by Steve on 20 Feb, 2012 06:36 PM

    Steve's Avatar

    Close mail.app
    then library > mail > bundles and that is where the bundle goes.

    I think I know understand what the problem might be:

    Please open GPG Keychain Access and double click your sec key. In the key inspector on the second tab (user ids) simply add an user id (+ sign for the top field) and enter the new address as you see it in mail as a user id.

    that way we can make sure gpg knows which key belongs to what account.

    hope this helps.

  4. 4 Posted by rmeike on 20 Feb, 2012 07:05 PM

    rmeike's Avatar

    I searched the following directories:

    library > application support
    system > library

    I didn't find a Mail folder in any of them. However, I did find:

    library > application support > apple > mail

    Do you think that would be a good place to put the .mailbundle file?

    Also, using the inspector in GPG Keychain doesn't work because you can only add an email address. "[email blocked] (iCloud)" is not a valid email address, so the inspector won't accept it.

    I really appreciate your help with this, Steve.

  5. 5 Posted by rmeike on 20 Feb, 2012 07:33 PM

    rmeike's Avatar

    There is no mail folder in the library folder at the root level of my hd. I'm kinda stuck here.

  6. Support Staff 6 Posted by Luke Le on 20 Feb, 2012 07:44 PM

    Luke Le's Avatar

    Hi Rusty,

    it's not at the root level, but in your user folder.
    It might be hidden, since that is the new default setting of Lion.

    Open Terminal.app and type the following line. Press enter once done.

    chflags nohidden ~/Library/

    After that you should see the Library folder in your home folder.

    Simply switch to ~/Library/Mail/Bundles and drop the new .mailbundle file there.

  7. 7 Posted by rmeike on 20 Feb, 2012 08:03 PM

    rmeike's Avatar

    Thanks. I was able to follow your instructions. Here's something interesting. In addition to the Bundles folder, there's also a folder called Bundles (Disabled). You'll never guess what's in there :)

    I'm thinking maybe I should move the old version of GPGMail.mailbundle back into the Bundles folder and see what happens before I try the new version. Any thoughts?

    ...and thanks for your help.

  8. Support Staff 8 Posted by Luke Le on 20 Feb, 2012 08:09 PM

    Luke Le's Avatar

    Aaah ok, it might be possible that the bundle was deactivated due to an OS X update.
    The problem is that apple doesn't support bundles for Mail.app, but tolerate them.
    As a consequence though, you have to specify with which version exactly you're plugin is compatible.
    Now if you update OS X and didn't update GPGMail, Mail.app doesn't accept GPGMail anymore and disables is by moving it into the Bundles (Disabled) folder.

    We're trying to release the new bundle before OS X is updated, but if you don't install that update, it's gonna be disabled.

  9. 9 Posted by rmeike on 20 Feb, 2012 08:12 PM

    rmeike's Avatar

    So should I completely reinstall GPGMail? Is that the best, most complete solution?

  10. Support Staff 10 Posted by Steve on 21 Feb, 2012 04:29 PM

    Steve's Avatar

    To simplify this: Could you run GPGTools-trunk.dmg (the GPGTools Installer) from here: http://nightly.gpgtools.org/. After that please let us know if everything is working again.

    Hope this helps.

  11. 11 Posted by rmeike on 21 Feb, 2012 04:41 PM

    rmeike's Avatar

    Sorry - I already reinstalled from GPGMail-2.0a30.dmg.zip. Everything is working fine. Thanks for all your help.

  12. Support Staff 12 Posted by Steve on 21 Feb, 2012 05:02 PM

    Steve's Avatar

    Even better. :)

    Feel free to open another discussion if you need further help.

  13. Steve closed this discussion on 21 Feb, 2012 05:02 PM.

  14. rmeike re-opened this discussion on 21 Feb, 2012 05:28 PM

  15. 13 Posted by rmeike on 21 Feb, 2012 05:28 PM

    rmeike's Avatar

    So just to wrap this up - it appears that when I installed iCloud, it modified Mail. During the modification process, GPGMail.mailbundle was put into a Bundles (Disabled) folder. So obviously it wasn't going to work.

    I probably could have just moved the original bundle back into the Bundles folder, but I went ahead and reinstalled. Simple process with the pkg that is available. All good now.

  16. Support Staff 14 Posted by Steve on 21 Feb, 2012 06:21 PM

    Steve's Avatar

    What you write is 100% correct, sir. :)

  17. Luke Le closed this discussion on 15 Mar, 2012 12:04 AM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts


? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac