GPG Services: Cmd + Shift + F shortcut cannot be disabled on MacOS

Grzegorz's Avatar


12 Feb, 2019 01:17 PM

I am using Intellij IDEA an Webstorm. There is a shortcut Cmd+Shift+F which Finds text in files (very often used). When I press it, my kay fingerprint is always inserted to the search field. I tried to disable the shortcut but it still pastes the fingerprint.

Shortcuts can be disabled

Additional info
Verrrrry annoying

macOS                   10.14.2     18C54
GPG Suite               2018.5      2368    (6f26711)
GPG Mail                3.0.1       1330    (807c323e)  30 trial days remaining
GPG Keychain            1.4.6       1514    (560b5a9)
GPG Services            1.11.6      1056    (ad0c960)
MacGPG                  2.2.10      921     (b487092)
GPG Suite Preferences   2.1.4       1077    (ad934a9)
Libmacgpg               0.8.7       895     (78f424a)
pinentry                1.1.0       10      (1ff8803)
  1. Support Staff 1 Posted by Steve on 12 Feb, 2019 01:19 PM

    Steve's Avatar

    Hi Grzegorz,

    thanks for getting in touch about this problem.

    We have already removed all default keyboard shortcuts to avoid collisions in our code already. While this is fixed in the nightly build and will be included in the next stable release unfortunately users with existing installations have to disable the shortcuts manually in System Preferences > Keyboard > Shortcuts > Services. Look for any OpenPGP: entry and remove the shortcuts as desired.

    As an alternative you could download and install our latest hotfix GPG Suite which will fix this problem.

    Hope this helps.


  2. 2 Posted by Grzegorz on 12 Feb, 2019 01:49 PM

    Grzegorz's Avatar

    Hi Steve,

    I did disable the shortcut but it still works. I have just uninstalled the GPGSuite and rebooted my Mac but the fingerprint is still pasted to the Find window in Webstorm.
    How it can be? Is there any leftover? I used the uninstaller app.

    Best regards,

  3. 3 Posted by Grzegorz on 12 Feb, 2019 02:00 PM

    Grzegorz's Avatar

    Ok, ignore my last comment, it was search history feature.

  4. Support Staff 4 Posted by Steve on 13 Feb, 2019 10:32 AM

    Steve's Avatar

    Glad this is solved for you. I'm closing this discussion. Should you need further assistance or have questions you can re-open this discussion here or open a new one any time.


  5. Steve closed this discussion on 13 Feb, 2019 10:32 AM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts


? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac