MacGPG: Cannot find certificates in LibreOffice

Luc Lalonde's Avatar

Luc Lalonde

27 Nov, 2018 09:13 PM

I cannot use the PGP certificate inside a LibreOffice document. I am able to do this in Linux and Windows with Kleoptatra...
Everything else seems to work with GPG-Suite. I'm able to sign emails (Thunderbird-Enigmail, iMail) and sign/encrypt files using Finder/Services.

Also, when I click on the certificate-manager button in LibreOffice, I get the error 'can't find the certificate manager'

Here's my setup: macOS Mojave, LibreOffice, GPG_Suite-2018.5

Thank You!

  1. Support Staff 1 Posted by Steve on 27 Nov, 2018 10:20 PM

    Steve's Avatar

    Hi Luc,

    welcome to the GPGTools support platform. Sorry you are having problems using GPG Suite.

    There is an open bug for Libreoffice #115538 which was files in february 2018 which addresses this problem:

    You may want to add your +1 to that bug to raise awareness of the LibreOffice dev departement.

    Sadly, there is nothing we can do to improve the situation on our side.


  2. 2 Posted by Luc Lalonde on 28 Nov, 2018 12:55 PM

    Luc Lalonde's Avatar

    Ok, just added my ‘mee too’...

  3. Support Staff 3 Posted by Luke Le on 28 Nov, 2018 12:56 PM

    Luke Le's Avatar

    Luc, back when I tried to debug this error I found that when LibreOffice is started from Terminal it works. So you might try that.

  4. 4 Posted by Luc Lalonde on 28 Nov, 2018 02:04 PM

    Luc Lalonde's Avatar

    This does not seem to work on Mojave...

  5. Support Staff 5 Posted by Luke Le on 28 Nov, 2018 02:35 PM

    Luke Le's Avatar

    Ah ok, that is possible. Last I tried it with was on a 10.11 system

  6. Support Staff 6 Posted by Luke Le on 28 Nov, 2018 02:38 PM

    Luke Le's Avatar

    Ah, you have to click on Sign Document…, Start Certificate manager… also errors out here. Not sure what the difference is, but Sign Document… shows my keylist when LibreOffice is started via Terminal:

  7. 7 Posted by Luc Lalonde on 28 Nov, 2018 04:09 PM

    Luc Lalonde's Avatar

    No, that does not work for me.

  8. Support Staff 8 Posted by Steve on 18 Sep, 2019 04:07 PM

    Steve's Avatar

    This needs to be fixed in LibreOffice and is the correct bug for the problem. They have raised priority but no fix in sight so far.

    Closing this discussion. Feel free to re-open if the LO bug is closed or you discover other news.

  9. Steve closed this discussion on 18 Sep, 2019 04:07 PM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts


? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac