decrypt button in OSX Mail does nothing, decrypting from services menus yields "decryption failed"

Matt's Avatar


08 Feb, 2012 11:21 PM

Hi guys. About every four years or so my brother wants to tell me some utterly benign story or development that he insists I install GPG to read about. In years past, I never had so much trouble. I made a better effort before to understand everything, but it would seem i have fallen farther than ever behind the curb. To give you an idea of what a computing dumb ass I am, I almost never use the command terminal.

Anyway, after all of his prodding, I thught I finally had everything installed and running. I received an encrypted email with the native OSX Mail client and the 'decrypt' button does nothing. I can 'depress' it, but that's all it does. If I highlight the text in any application, I get an error saying 'decryption failed.'

I need aux brainpower input.



  1. Support Staff 1 Posted by Luke Le on 08 Feb, 2012 11:38 PM

    Luke Le's Avatar

    Hi Matt,

    I'll promise you, we won't fail you!
    But first we need some more info from you:

    • What version of GPGTools did you install?
    • What version of OS X are you running?
  2. 2 Posted by Matt on 09 Feb, 2012 12:02 AM

    Matt's Avatar

    Hi! Thanks for the quick response! I'm rnning 10.6.8 and installed the 12/24/2011 gpg tools.

    I must step out for a bit now, but I'll be back. I apologize for initiating this thread just as my boss is sending me out.

    Thanks again,


  3. Support Staff 3 Posted by Luke Le on 09 Feb, 2012 12:03 AM

    Luke Le's Avatar

    Hehe, no worries. It's already pretty late here, so I'll probably follow up tomorrow with additional debug steps.

  4. Support Staff 4 Posted by Steve on 15 Feb, 2012 03:25 PM

    Steve's Avatar

    Hey Matt,

    thanks for your interest in our tools. I'm not sure what exactly your problem is. To make sure you get the basics: please read the Quickstart Tutorial linked on our startpage: (in the middle black box) and consider watching the screencast. Problem is, we describe the latest GPGMail in those documents. Please provide all the info you have regarding your issue and fill the form from here:

    Any reason why you don't want to update to 10.7? The latest GPGMail 2.0 is currently only for 10.7 and the whole team is using the latest OS so it's rather difficult to provide support for older OS systems.

  5. 5 Posted by CB on 21 Feb, 2012 11:18 PM

    CB's Avatar

    I have the same problem as listed above. I can send encrypted ok but I can't decrypt once someone replies back. I'm on 10.6.8 and I just installed the GPGTools-20111224.dmg version. I've had this problem before and I tried the GPGFix option in the system prefs and that didn't work either. I suppose I could try updating to 10.7 to see if that would help.

  6. Support Staff 6 Posted by Steve on 24 Feb, 2012 09:47 AM

    Steve's Avatar

    Hey CB,

    well if you really want to update to 10.7 go ahead. We'd be glad to hear from you again. Please let us know if your problems could be solved.

    As for 10.6.8 I'm not sure what the problem could be. Are you sure the sender is using the correct public key?

    I couldn't find a key for your mail address on the key servers. If you'd give us your public key, we could send you a test message.

    All the best, steve

  7. 7 Posted by buhl on 24 Feb, 2012 01:29 PM

    buhl's Avatar


    I really appreciate you following up about this.

    I have just installed 10.7, and have some issues to work out today before I readdress my problem with GPG and come back to ask for your help.

    Thanks again!

  8. Support Staff 8 Posted by Steve on 24 Feb, 2012 01:43 PM

    Steve's Avatar

    Ok, thanks for the heads-up. Looking forward to getting you setup! :)

  9. 9 Posted by Alex on 04 Mar, 2012 09:56 PM

    Alex's Avatar

    Does the installer from work for you?

  10. 10 Posted by buhl on 04 Mar, 2012 10:04 PM

    buhl's Avatar


    Ive just installed 10.7 (was running 10.6), will try all again and get back. Thanks a bunch for your persistence!


  11. Support Staff 11 Posted by Steve on 05 Mar, 2012 09:24 AM

    Steve's Avatar

    Sure, keep us posted. :)

  12. 12 Posted by Avery on 09 Mar, 2012 09:42 AM

    Avery's Avatar

    I have the same problem as the original poster. I'm running 10.7.3 with gpg 2.0.17 (running the same version as the OP). I can decrypt my message with gpg on the commandline but using the services menu results in the same result as the OP.

  13. Support Staff 13 Posted by Steve on 10 Mar, 2012 07:40 AM

    Steve's Avatar

    Hey Avery. Could you try the nightly installer from here: ?

    It contains an updated MacGPG2 and the latest GPGServices. Let us know if that helps.

  14. 14 Posted by Avery Chan on 15 Mar, 2012 01:03 AM

    Avery Chan's Avatar

    OK, I just tried it. It works under some conditions, but not always. It works if I just select the file and tell services to decrypt the file (from the Finder).

    But it doesn't work when I open an encrypted file in TextWrangler and then from Services select 'Decrypt selection'. It also doesn't work when I use LaunchBar to select a file in the Finder and then 'Instant Send' it to the 'Decrypt File' Services command. In the former example, it spins for a while and then displays: "The 'OpenPGP: Decrypt Selection' service could not be used because the application did not respond to a request for services. In the latter, it displays the same 'decryption failed' notice
    Avery Chan | Co-founder (

  15. 15 Posted by Alex on 17 Mar, 2012 02:20 PM

    Alex's Avatar

    This discussion is now a mixture of different requests from different users. Please create a new discussion if there are open issues with the latest nightlies. So we can handle them seperately. Thanks a lot.

  16. Alex closed this discussion on 17 Mar, 2012 02:20 PM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts


? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac