GPGMail gpg-agent not working

Aljaž Srebrnič's Avatar

Aljaž Srebrnič

08 Feb, 2012 01:16 PM

I've installed gpg2 and gpg-agent via MacPorts, and then only GPGmail, GPGPreferences and GPG Keychain Access (I prefer it this way so the gpg binaries are kept updated by MacPorts). I'm noticing that GPGMail is not starting gpg-agent, so it doesn't "remember" the password. "use-agent" is defined in gpg.conf and using gpg directly from command line spawns a daemon correctly. What am I missing?

  1. 1 Posted by Aljaž Srebrnič on 08 Feb, 2012 01:19 PM

    Aljaž Srebrnič's Avatar

    Ah, another small issue: When I select encrypt or sign in Mail, the label 'OpenPGP' appears in the upper right corner of the compose window, but the background is not green, it's the default background! System is 10.7.3

  2. Support Staff 2 Posted by Luke Le on 08 Feb, 2012 02:58 PM

    Luke Le's Avatar

    Hi Aljaz,

    the gpg-agent issue is a bit tricky.

    Before 2.0.18 gpg-agent needed to be launched via launchd so gpg2 could use it.
    If you use our packages that's all taken care of.

    There's a good chance MacPorts doesn't launch it for you, doesn't launch it correctly or you were shown a command after compiling which you didn't run in Terminal which also would take care of launching it for you.

    If MacPort already has 2.0.18 you should install that version, since starting with that version gpg2 will handle launching the gpg-agent on its own.

    If 2.0.17 is not available via MacPorts it's best to use our package.

    As for the green background, that's not enabled by default yet but you can enable it by running the following command in

    defaults write org.gpgtools.gpgmail UseNonMonochromeEncryptionMethodHint -bool YES

    Relaunch to see the change.

    Hope that helps

  3. 3 Posted by Aljaž Srebrnič on 08 Feb, 2012 03:56 PM

    Aljaž Srebrnič's Avatar

    Thanks for the quick response, Luke!
    I have version 2.0.18... :/

    And thanks for the command, the bg is now green, yay! ;)

  4. 4 Posted by Aljaž Srebrnič on 08 Feb, 2012 03:58 PM

    Aljaž Srebrnič's Avatar

    Never mind!
    I tried reinstalling gnupg2 from MacPorts and now it works perfectly! Thanks for your work guys!

  5. Support Staff 5 Posted by Luke Le on 08 Feb, 2012 04:32 PM

    Luke Le's Avatar

    Fantastic! Always glad to hear a problem could be solved!
    Feel free to open a new discussion if you run into
    problems again!

  6. Luke Le closed this discussion on 08 Feb, 2012 04:32 PM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts


? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac