GPGMail buttons not showing on compose window

Wayne Beaver's Avatar

Wayne Beaver

25 Sep, 2018 09:15 PM

Which of our tools is giving you problems?

GPGMail

Attach a screenshot of the version info for all installed components (how to: https://gpgtools.tenderapp.com/kb/faq/where-can-i-find-version-info...):

See Attachment

Describe your problem. Add as much detail as possible.

I updated GPG suite to v10.13.6. The e-mail address of my Mail.app default account matches the e-mail address for GPG key. I also did a full restarts after install. I'm not seeing GPGMail-related buttons in my Mail.app compose window. I'm also not seeing any options in Mail.App preferences. OSX 10.13.6

I think sometime earlier this year I I disabled GPGMail in-line decryption with Mail.app, due to the eFail vulnerability scare. IIRC, one of the workarounds for that was to delete "/Library/Mail/Bundles/GPGMail.mailbundle/", but my "/Library/Mail/Bundles/GPGMail.mailbundle/" tree appears intact, with most of the files dated 2018-06-13 and an "Info.plist" dated 2018-09-25

What did you expect instead

GPGMail buttons displayed in compose window

Describe steps leading to the problem.

I updated GPG suite to v10.13.6.

Are you using any other Mail.app plugins?

No

  1. 1 Posted by Wayne Beaver on 25 Sep, 2018 09:17 PM

    Wayne Beaver's Avatar

    Looks like attachment may not have posted. Trying again.

  2. Support Staff 2 Posted by Steve on 25 Sep, 2018 11:19 PM

    Steve's Avatar

    Hi Wayne,

    welcome to the GPGTools support platform. Sorry you are having problems using GPG Suite.

    Could you please send a debug log from your affected machine: Open System Preferences > GPG Suite > Send Report. Check the box to "attach debug log". Since you already described your issue in this discussion, you don't need to add a lot of detail, but please do add the link to your existing discussion, so I can then merge your debug info with this existing discussion.

    All the best,
    steve

  3. 3 Posted by Wayne Beaver on 26 Sep, 2018 12:08 AM

    Wayne Beaver's Avatar

    No longer required. I did a complete uninstall (via manual file-deletion), then a “software update” from either “Systems Preferences -> GPG Suite”, or the GPG Keychain Access app (I don’t recall, which), instead of “Download from the website and install via the DMG”. I’m not suggesting the DMG method won’t work - my brute-force uninstall may have been the key…

    Anyway, all solved now, case closed. Thanks for your speedy reply.

    wb

  4. Support Staff 4 Posted by Steve on 26 Sep, 2018 10:13 AM

    Steve's Avatar

    Glad, this is solved for you. I'm closing this discussion. Should you need further assistance or have questions you can re-open this discussion here or open a new one any time.

    Best,
    steve

  5. Steve closed this discussion on 26 Sep, 2018 10:13 AM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac