Mail nonfunctional

Joshua's Avatar

Joshua

24 Sep, 2018 01:14 PM

Since installing GPGTools 2018 on Mojave, my Mail “launches” but does nothing. It can’t even show my mailbox anymore. This happens even after uninstalling GPGTools!

Expected
For everything to work.

macOS                   10.14       18A389
GPG Suite               2018.4      2310    (bc31914)
GPG Mail                3.0         1328    (82e5a048)  30 trial days remaining
GPG Keychain            1.4.5       1496    (25530e6)
GPG Services            1.11.5      1033    (86cb937)
MacGPG                  2.2.10      921     (b487092)
GPG Suite Preferences   2.1.3       1057    (966febd)
Libmacgpg               0.8.6       885     (35a18be)
pinentry                0.9.7.1     9       (db18340)
  1. Support Staff 1 Posted by Steve on 18 Oct, 2018 03:57 PM

    Steve's Avatar

    Hi Joshua,

    welcome to the GPGTools support platform. Sorry you are having problems using GPG Suite.

    Please excuse the late reply, we are deeply sorry for not responding earlier. The amount of feedback we received in regards to the GPG Suite 2018.4 release was overwhelming. We are doing our best to catch up as fast as we can.

    Could you please download and install our latest hotfix GPG Suite and see if that solves your problem.

    Hi ,

    welcome to the GPGTools support platform. Sorry you are having problems using GPG Suite.

    If you have just recently upgraded to macOS Mojave and can‘t find any signs of GPG Mail: Apple disables any installed plugins after installation and they have to be enabled manually.

    Let me know if this did the trick.

    All the best,
    Steve

    Disclaimer: This is a development version which has not been thoroughly tested yet - bugs or crashes are to be expected. Thanks for helping us test.

  2. 2 Posted by Dmitriy Lyalyue... on 31 Oct, 2018 12:44 PM

    Dmitriy Lyalyuev's Avatar

    I've tried to install your dev build, but it doesn't help.

    What I can do to get Mail working even without GPGTools?

  3. Support Staff 3 Posted by Luke Le on 31 Oct, 2018 01:02 PM

    Luke Le's Avatar

    Hi,

    following are the steps that should fix this problem:

    Close Mail.app
    Open Terminal and run the following command:
    sudo rm -rf ~/Library/Containers/com.apple.mail/Data/DataVaults

    Open Mail.app

    Hope that helps.

  4. Support Staff 4 Posted by Luke Le on 31 Oct, 2018 01:02 PM

    Luke Le's Avatar

    We have reported this bug to Apple, but it might take some time for them to fix this problem.

  5. 5 Posted by Dmitriy Lyalyue... on 31 Oct, 2018 01:04 PM

    Dmitriy Lyalyuev's Avatar

    Thanks for the answer.

    Removing empty /Library/Mail/Bundles folder resolve my issue. Maybe it will help someone else.

  6. Support Staff 6 Posted by Steve on 31 Oct, 2018 05:05 PM

    Steve's Avatar

    @Joshua could you try the steps Luke posted earlier today and let us know if that fixes the situation for you?

    Best,
    Steve

  7. 7 Posted by Bob Gao on 07 Nov, 2018 07:51 AM

    Bob Gao's Avatar

    Same issue, just tried empty /Library/Mail/Bundles folder and mail start again, thanks for @Dmitriy.

  8. Support Staff 8 Posted by Steve on 14 Nov, 2018 01:38 PM

    Steve's Avatar

    Closing, since no further user feedback from Joshua was received. Should your problem persist, feel free to re-open this discussion any time.

    All the best, steve

  9. Steve closed this discussion on 14 Nov, 2018 01:38 PM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac