GPG Mail: GPG Suite for Mac

Christian Winter's Avatar

Christian Winter

23 Sep, 2018 07:38 PM

I have just updated to the latest version released just days ago: I have two keypairs, of which one is set to be the default key for mail encryption. However, when using this key to encrypt and sign the new version of GPGMail uses the default key for encryption and the second key for signing, which in my eyes should not happen because the second key is not public I only use it for encrypting local files, not for mail.

Expected
I expect that the default key will be used for mail encryption and signing.

macOS                   10.13.6     17G65
GPG Suite               2018.4      2310    (bc31914)
GPG Mail                3.0         1330    (724e6997)  30 trial days remaining
GPG Keychain            1.4.5       1496    (25530e6)
GPG Services            1.11.5      1033    (86cb937)
MacGPG                  2.2.10      921     (b487092)
GPG Suite Preferences   2.1.3       1057    (966febd)
Libmacgpg               0.8.6       885     (35a18be)
pinentry                0.9.7.1     9       (db18340)
  1. Support Staff 1 Posted by Steve on 24 Oct, 2018 06:52 PM

    Steve's Avatar

    Hi Christian,

    welcome to the GPGTools support platform. Sorry you are having problems using GPG Suite.

    In case you are not looking to use one of the two keys publicly, it would be a good idea to revoke the email address in that key. You can just use a blank email field in that case. And that would solve this problem.

    Can you explain the use case you are looking to cover with this setup?

    Best,
    Steve

Reply to this discussion

Internal reply

Formatting help / Preview (switch to plain text) No formatting (switch to Markdown)

Attaching KB article:

»

Attached Files

You can attach files up to 10MB

If you don't have an account yet, we need to confirm you're human and not a machine trying to post spam.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac