Latest firmware update on 2018 MacBook Pro makes key unusable

Tim Reynolds's Avatar

Tim Reynolds

30 Aug, 2018 10:24 AM

Debug Log



Hi,

I created a GPG key and then installed GPGTools last month mostly for use with the git cli tool to sign commits. The suite allowing the key password to be stored in the 'keychain'.

Since applying the Apple issued firmware update git has been unable to access the key as has mail.

I've checked and I'm running the latest version.

Anything else I can send to help with this? I've got crash reports turned on too.

  1. Support Staff 1 Posted by Steve on 02 Sep, 2018 05:56 PM

    Steve's Avatar

    Hi Tim,

    welcome to the GPGTools support platform. Sorry you are having problems using GPG Suite.

    Did you install a custom gpg version in the meantime with fink/macports/brew/homebrew/from source? If so, could you remove it, repeat the steps and see if you are still running into the error message.

    Best,
    steve

  2. 2 Posted by Tim Reynolds on 03 Sep, 2018 06:15 PM

    Tim Reynolds's Avatar

    I looked into this and don’t believe I did. It would have been brew and the list command doesn’t show it

  3. Support Staff 3 Posted by Steve on 03 Sep, 2018 09:28 PM

    Steve's Avatar

    Could you please send a debug log from your affected machine: Open System Preferences > GPG Suite > Send Report. Check the box to "attach debug log". Since you already described your issue in this discussion, you don't need to add a lot of detail, but please do add the link to your existing discussion, so I can then merge your debug info with this existing discussion.

  4. 4 Posted by Tim Reynolds on 06 Sep, 2018 10:24 AM

    Tim Reynolds's Avatar

    Just tried doing this but got the following error twice, no idea why.

  5. Support Staff 5 Posted by Steve on 06 Sep, 2018 11:42 AM

    Steve's Avatar

    We've changed a few things in the backend. Could you retry to send the report. Maybe that way we can learn what's going wrong.

  6. 6 Posted by Tim Reynolds on 06 Sep, 2018 12:53 PM

    Tim Reynolds's Avatar

    Still getting the same issue.

    Anyway I can find the log file manually to send it?

  7. Support Staff 7 Posted by Steve on 06 Sep, 2018 01:43 PM

    Steve's Avatar

    Can you please retry another time? It should be working fine now. Thanks for your patience and also thanks for helping us find the problem which we think should now be fixed.

  8. 8 Posted by Tim Reynolds on 06 Sep, 2018 02:59 PM

    Tim Reynolds's Avatar

    Great that worked this time

  9. Support Staff 9 Posted by Luke Le on 06 Sep, 2018 03:20 PM

    Luke Le's Avatar

    Hi Tim,

    the debug log shows that there is in fact a second version of gnupg installed on your system and I strongly believe that that is causing the problems.

    The easiest fix is to move the second version of GnuPG by running the following command:

    sudo mv /usr/local/bin/gpg /usr/local/bin/gpg-v2.2.9
    sudo ln -s /usr/local/MacGPG2/bin/gpg2 /usr/local/bin/gpg
    killall gpg-agent; killall dirmngr; killall scdaemon
    

    After that, your setup should be working again.

Reply to this discussion

Internal reply

Formatting help / Preview (switch to plain text) No formatting (switch to Markdown)

Attaching KB article:

»

Already uploaded files

  • Screen_Shot_2018-08-30_at_11.20.26.png 153 KB
  • Screen_Shot_2018-08-30_at_11.23.39.png 175 KB

Attached Files

You can attach files up to 10MB

If you don't have an account yet, we need to confirm you're human and not a machine trying to post spam.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac