GPGServices: GPG Service French Translation show German strings

Guillaume's Avatar

Guillaume

25 Jul, 2018 07:06 PM

French language setting. Select a file, right click, services, OpenPGP Encryt.
The resulting window is not in French but in a mix of English and German

Expected
Either French translated interface or Mix of French and English (Or English), but not german translation strings.

macOS                   10.13.6     17G65
GPG Suite               2018.3      2223    (8d0c266)
GPGMail                 3.0b7       1319    (c2d0df0a)
GPG Keychain            1.4.4       1460    (9010342)
GPGServices             1.11.4      1013    (0b04f6c)
MacGPG                  2.2.8       916     (0ed4a99)
GPG Suite Preferences   2.1.2       997     (1a09bc7)
Libmacgpg               0.6.1       0n      (-)
pinentry                0.9.7.1     9       (db18340)
  1. Support Staff 1 Posted by Steve on 29 Jul, 2018 11:49 AM

    Steve's Avatar

    Hi Guillaume,

    welcome to the GPGTools support platform. Sorry you are having problems using GPG Suite.

    Can you please open System Preferences > Language & Region and send us a screenshot of that settings.

    Please create another screenshot of the GPGServices window with the language mix of german and english.

    One thing in your report sticks out: The Libmacgpg version 0.6.1 0n is an unofficial version. Did you ever install a test build we specifically sent you for debugging purposes?

    Could you please download and install our latest hotfix GPG Suite and see if that solves your problem. Please run the uninstaller first before installing the nightly build. After that please send another report from System Preferences > GPG Suite Preferences including a link to this specific discussion here so we can again take a closer look at the version installed on your system.

    All the best,
    steve

    Disclaimer: This is a development version which has not been thoroughly tested yet - bugs or crashes are to be expected. Thanks for helping us test.

  2. 2 Posted by Guillaume Didie... on 29 Jul, 2018 12:34 PM

    Guillaume Didier's Avatar

    The issue was in the Language & Region Pref Pane, where the settings were incorrect.
    (Also known as problem between keyboard and chair)
    Solved for me (also updated libmacgpg to the latest nightly, this was likely a leftover from when I attempted to install gpgtools from source)

    Thanks for the answer.

  3. Support Staff 3 Posted by Steve on 29 Jul, 2018 02:40 PM

    Steve's Avatar

    That's great news. Glad you were able to figure the culprit of the probelm.

    I'm closing this discussion. Should you need further assistance or have questions you can re-open this discussion here or open a new one any time.

    Best,
    steve

  4. Steve closed this discussion on 29 Jul, 2018 02:40 PM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac