GPGTools cannot encrypt text (using textedit)

Alfredo's Avatar


29 Jan, 2012 08:42 AM

I am trying to do something very simple: take a message I've written in textedit, encrypt it, and append my public key.

Currently when I select text to encrypt (right click, go to services) I don't see any of the GPG options there. What I can do is save the file, right click, and go to services where I'll find the option to encrypt the file. However, opening the file in the txtedit reveals some weird symbols. Usually a PGP encrypted message should look like

--BEGIN PGP MESSAGE-- (stuff goes here)


Instead it's just a bunch of randomly spaced jargon. Note that I can encrypt mail properly using enigmail and thunderbird (using this particular key).

Any ideas on what to do?

  1. Support Staff 1 Posted by Luke Le on 29 Jan, 2012 08:55 AM

    Luke Le's Avatar

    Hi Alfredo,

    the mangled message you see might be the binary encrypted version of your text.
    Usually GPGServices should armor the text using base64 to convert it to ASCII, but for some reason it seems to fail.
    Could you try if the nightly works for you?

    Hope that helps

  2. 2 Posted by Alfredo on 29 Jan, 2012 10:37 AM

    Alfredo's Avatar

    The nightly build worked perfectly. I had already enabled the GPG shortcuts in the keyboard shortcuts menu of system preferences but they didn't work in the other build. Encrpytion, signing, etc. now work perfectly both within textedit and on the file.

  3. Support Staff 3 Posted by Luke Le on 29 Jan, 2012 10:39 AM

    Luke Le's Avatar

    Very glad to hear that!
    We'll release this build soon.

    If you run into problems again, feel free to open a new discussion :)

  4. Luke Le closed this discussion on 29 Jan, 2012 10:39 AM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts


? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac