GPGServices: Can't find route to key-server

Daryle Walker's Avatar

Daryle Walker

13 Jun, 2018 07:49 AM

Search keys failed! (No route to host)
Code = 32810
Error text:
gpg: error searching keyserver: No route to host
gpg: keyserver search failed: No route to host

Expected
Searching for “Tor” to work.

Additional info
I first tried through the command line, based on Tor’s directions at https://www.torproject.org/docs/verifying-signatures.html.en:

$ gpg --keyserver pool.sks-keyservers.net --recv-keys 0x4E2C6E8793298290 gpg: keyserver receive failed: No route to host

macOS                   10.13.5     17F77
GPG Suite               2018.2      2199    (bef9c89)
GPGMail                 3.0b6       1316    (3d99a0fc)
GPG Keychain            1.4.3       1410    (9800780)
GPGServices             1.11.3      973     (5ebfa20)
MacGPG                  2.2.7       902     (099ae46)
GPG Suite Preferences   2.1.2       997     (1a09bc7)
Libmacgpg               0.8.4       853     (89d8783)
pinentry                0.9.7.1     9       (db18340)
  1. Support Staff 1 Posted by Steve on 23 Jun, 2018 11:47 AM

    Steve's Avatar

    Hi Daryle,

    unfortunately there are a variety of reasons why a key search can fail.

    Is there any chance that you are using Little Snitch or any other firewall on your Mac? If so, please temporarily disable that software and repeat your key search.

    If the problem persists, please open Terminal and run the following commands to create some debug output for us:

    echo "debug-level guru" >> ~/.gnupg/dirmngr.conf
    echo "debug-all" >> ~/.gnupg/dirmngr.conf
    echo "log-file /tmp/dirmngr.log" >> ~/.gnupg/dirmngr.conf
    killall dirmngr
    gpg --search-keys [email blocked]
    gpg --keyserver hkps://hkps.pool.sks-keyservers.net --search-keys [email blocked]
    

    After running these commands, please send us the /tmp/dirmngr.log file

    1. open finder and press ⇧⌘G
    2. paste /tmp/dirmngr.log
    3. attach the dirmngr.log file to this discussion

    Once you are done, it's best to remove the debugging option:

    1. open finder and press ⇧⌘G
    2. paste ~/.gnupg/dirmngr.conf
    3. open that file with TextEdit
    4. remove the following lines
      • debug-level guru
      • debug-all
      • log-file /tmp/dirmngr.log

    Now open Terminal.app again and execute the following commands:

    rm /tmp/dirmngr.log killall dirmngr

    Best,
    steve

  2. Steve closed this discussion on 05 Sep, 2018 05:13 PM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac