selecting About->Fix GPGTools in GPGPreferences PreferencePane breaks command line GPG :(

Casemon's Avatar


27 Jan, 2012 12:44 AM

decrypt was working fine from cmd-line
had an issue with one particular msg and opted to select About->Fix GPGTools in GPGPreferences PreferencePane.
after running, retried cmd-line decrypt and it now gives error:

gpg: /Users//.gnupg/gpg.conf:236: invalid option

Lines 235 & 236 are this:
comment GPGTools -

(note missing comment # sign on 235... )

Commenting out both lines restored cmd-line functionality.

Hope this helps :)

  1. Support Staff 1 Posted by Luke Le on 27 Jan, 2012 12:51 AM

    Luke Le's Avatar


    Thanks for the great bug report.
    The problem seems to be your "no-use-standard-socket" option.
    Did you put that there intentionally or was this from an old installation?

    Not sure why, but "no-use-standard-socket" no longer belongs into gpg-agent.conf.
    Maybe this is since version 2.x and could stay in gpg.conf in version 1.x.

    We'll investigate this further

  2. Support Staff 2 Posted by Steve on 18 Feb, 2012 11:38 PM

    Steve's Avatar

    Dear Casemon, thanks for the report. This is a serious problem and we'll try to fix it sometime soon.

    Feel free to subscribe to the ticket if you want to be informed about updates:

    Closing this discussion.

    All the best :)

  3. Steve closed this discussion on 18 Feb, 2012 11:38 PM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts


? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac