GPGMail: Signing can't be disabled in GPGMail after a smartcard failure

T Wilson-Brown's Avatar

T Wilson-Brown

18 May, 2018 01:56 AM

When my Yubikey fails to sign an email, and I disable signing on that email, GPGMail still signs the email.

Steps to reproduce:
1. Compose an email with signing on by default
2. Send the mail, but give the wrong smartcard PIN
3. Disable signing on the email
4. Send the mail

GPGMail attempts to sign the mail, even though signing is disabled.

Expected
When signing is disabled, GPGMail does not sign mail.

macOS                   10.13.2     17C205
GPG Suite               2018.1      2083    (9658b70)
GPGMail                 3.0b4       1272    (461cda15)
GPG Keychain            1.4.2       1403    (128637e)
GPGServices             1.11.2      969     (e5438f7)
MacGPG                  2.2.3       900     (cead4f9)
GPG Suite Preferences   2.1.1       993     (05eb1a6)
Libmacgpg               0.8.2       829     (943132e)
pinentry                0.9.7.1     9       (db18340)
  1. Support Staff 1 Posted by Steve on 06 Jul, 2018 05:02 PM

    Steve's Avatar

    Hi Tim,

    thanks for taking the time to file this report. The problem is reproducible (also without smartcard).

    We have a ticket for this problem. I connected this discussion with the existing ticket. That means, should this discussion get closed, it will be re-opened as soon as the ticket is closed. That way you'll stay in the loop and get notified as soon as we have news. Feel free to open a new discussions should you run into further problems or need assistance.

    Best,
    steve

Reply to this discussion

Internal reply

Formatting help / Preview (switch to plain text) No formatting (switch to Markdown)

Attaching KB article:

»

Attached Files

You can attach files up to 10MB

If you don't have an account yet, we need to confirm you're human and not a machine trying to post spam.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac