GPG Suite Preferences: Keyservers not working

Biechele's Avatar

Biechele

27 Apr, 2018 12:48 PM

Hi support,

how can I add another keyserver to GPG Suite under "Preferences"? Non of the specified servers are working. So I can’t search or publish a key.

Thank you. Best regards,
Josef

Expected
Expected it to be working ;)

Additional info
no additional info

macOS                   10.10.5     14F2511
GPG Suite               2018.1      2083    (9658b70)
GPGMail                 2.6.4       1249    (d765eca)
GPG Keychain            1.4.2       1403    (128637e)
GPGServices             1.11.2      969     (e5438f7)
MacGPG                  2.2.3       900     (cead4f9)
GPG Suite Preferences   2.1.1       993     (05eb1a6)
Libmacgpg               0.8.2       829     (943132e)
pinentry                0.9.7.1     9       (db18340)
  1. 1 Posted by Biechele on 27 Apr, 2018 02:35 PM

    Biechele's Avatar

    SOLVED!
    The reason was a rule for Little Snitch, which blocked process "dirmngr" for outgoing connections. Changed it to "Allow" and now at least this predefined keyserver: hkp://pool.sks-keyservers.net works.

    Thanks for the quick support and the Knowledge Base articles ;)
    J.

  2. 2 Posted by Josef Biechele on 27 Apr, 2018 02:42 PM

    Josef Biechele's Avatar

    Thank you for the quick Response.

    I found the reason by checking the Knowledge Bases, should have done that first, sorry.

    The reason was a Little Snitch rule that prevented process "dirmngr" from outgoing connections. Changing the rule to "allow" makes the keyserver settings work, at least for this one: hkp://pool.sks-keyservers.net <hkp://pool.sks-keyservers.net>

    I added a comment to the post.

    Best regards,
    Josef

    > On 27.04.2018, at 14:48, GPGTools <[email blocked] <mailto:[email blocked]>> wrote:
    >
    > [GPGTools] Thanks for your feedback
    >
    > Dear Biechele,
    >
    > thanks for your interest in GPG Suite.
    >
    > We've received your message. Please allow a few days for us to respond.
    >
    > Meanwhile we suggest consulting our Knowledge Base [1] and search existing discussions [2] which may cover just the solution you are looking for.
    >
    > Since this is a community forum, other users may respond and help get you sorted before we do, should your discussion be 'public'. This does of course not apply to discussions set to 'private' [3].
    >
    > Your new discussion is here:
    > https://gpgtools.tenderapp.com/discussions/problems/73259-gpg-suite-preferences-keyservers-not-working <https://gpgtools.tenderapp.com/discussions/problems/73259-gpg-suite-preferences-keyservers-not-working>
    >
    > Best regards,
    > Your GPGTools team
    > https://gpgtools.org
    >
    > --
    > [1] Knowledge Base: https://gpgtools.tenderapp.com/kb
    > [2] Public discussions: https://gpgtools.tenderapp.com/discussions
    > [3] GPGTools support community: https://gpgtools.tenderapp.com/kb/faq/how-to-best-use-this-support-forum

  3. Support Staff 3 Posted by Steve on 29 Apr, 2018 10:47 AM

    Steve's Avatar

    Hi Josef,

    welcome to the GPGTools support platform. Sorry you are having problems using GPG Suite.

    Great to hear you already were able to solve this yourself. Are you able to switch to hkps://hkps.pool.sks-keyservers.net in System Preferences > GPG Suite Preferences? You may want to use that key server instead of the "normal" hkp because hkps offers encrypted communication with the key servers.

    Enjoy your weekend,
    steve

  4. 4 Posted by Josef on 29 Apr, 2018 11:03 AM

    Josef's Avatar

    Hi Steve,

    thanks for your response and the hint. After repeated attempts, yes it works to switch to
    hkps://hkps.pool.sks-keyservers.net

    All the best,
    Josef

  5. Support Staff 5 Posted by Steve on 29 Apr, 2018 01:06 PM

    Steve's Avatar

    So it just now did not work on the first attempt? If so, what was the error you were seeing?

    Does that error persist with the nightly build? Could you please download and install our latest hotfix GPG Suite and see if that solves your problem.

    All the best,
    steve

    Disclaimer: This is a development version which has not been thoroughly tested yet - bugs or crashes are to be expected. Thanks for helping us test.

  6. 6 Posted by Josef Biechele on 29 Apr, 2018 01:41 PM

    Josef Biechele's Avatar

    Hi again,

    my initial problem was that I could not assign any key server in the "Preferences", always getting the same message: "Bad key server. …". The reason was my blocked outgoing connection for process "dirmngr", blocked by a Little Snitch rule. Solved by allowing outgoing connections via process "dirmngr".

    Before the nightly build version, I always got the same message "Bad key server. …" when I tried to select a key server with the hkps:// protocol. That’s why I had assigned this one: hkp://pool.sks-keyservers.net <hkp://pool.sks-keyservers.net>.

    Now with the nightly build: Version 1.4.2 (bf93c07) (1433n) the first attempt to assign hkps://hkps.pool.sks-keyservers.net <hkps://hkps.pool.sks-keyservers.net> showed the same message "Bad key server. …". But after one or two more attempts it now works. And it also works with all other key servers in the select list.

    Thank you for your efforts.
    Have a great day,
    Josef

  7. Support Staff 7 Posted by Steve on 29 Apr, 2018 01:43 PM

    Steve's Avatar

    Ok, thanks for the detailed feedback. I was asking because there are a few things that changed regarding key servers after the update from MacGPG 2.0 to 2.2. In the past days a lot of work went into improving this situation.

    So if you run into any further error messages using the nightly build please do let us know.

    Glad, this is now solved for you. I'm closing this discussion. Should you need further assistance or have questions you can re-open this discussion here or open a new one any time.

    Best,
    steve

  8. Steve closed this discussion on 29 Apr, 2018 01:43 PM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac