me too, but different: GPGMail don't show encripted messages (web)

felix's Avatar


25 Jan, 2012 09:32 PM

Hej folks at support.gpgtools!!

You're doing a very good job. Thank you. I just upgraded to Lion, still using apple mail combined with gpgmail. Although I don't like to have less preferences in Lion than I had in Snow Leopard before - I still like the integration (I did use the presets like "don't encrypt" while composing and similar).

Ok - now: my problem is same as here:

BUT: The encrypted mail I sent to a recipient doesn't open in my client. I did check expiring dates of my standard private key and recipient's public one. Both > 2013-01-01.

Additional upper right corner doesn't turn to green while composing an encrypted mail (as it shown here: Screenshot on

Any ideas!?

thx a lot in advance!!


  1. Support Staff 1 Posted by Luke Le on 25 Jan, 2012 10:18 PM

    Luke Le's Avatar

    Hi Felix,

    first off, thanks for the kind words!
    We're continously trying to improve GPGMail but due to
    a necessary complete rewrite for Lion, we've removed
    any preferences we didn't consider as extremely necessary
    to make it easier to use.
    However we'll add most of the necessary options as we find time
    and a clever and easy to use way.

    The automatic decryption will be optional in the upcoming version.

    As for your problem, if you're trying to encrypt to a recipient you can't read
    the messages yourself unless you have their private key.
    Also, the mail address you use to send an encrypted mail to must
    at the moment be exactly the same as the one connected to
    the recipients Key.

    There's a good chance though, I didn't understand your problem
    completely. Could you post an example?

  2. 2 Posted by felix on 25 Jan, 2012 11:23 PM

    felix's Avatar

    Hej Luke Le!

    Thank you for your QUICK!!! answer! I understand
    that's hard work to upgrade all features to lion.
    And I appreciate if you try to manage things easier.

    I'll try to explain my prob the non technical way.

    • I compose an email to somebody I sometimes send encrypted mails

    • due tue not being used to check whether the message is encrypted or not (that's the missing preset I'm so used to... ,-) ) I send this message encrpted - even if didn't want to.

    • It's a long message. As far as I remember (?) I was always able to read the messages I did write to somebody.

    • Now a the long email is gone to the recipient. ...and I don't know what I've written. Well - I still know today by heart. But tomorrow? For documentation I need the emails. Decrypted.

    Am I wrong with what I remember? Is it also just a
    feature not implemented yet?
    If so - would it be the best workaround to add
    myself to the recipients list?

    ...I'm a bit confused... (but - luckily - still ok)

    My further thoughts: To prevent somebody from
    sending such an email you implemented the
    "green corner" which says "OpenPGP" as in the mentioned screenshot. My Client doesn't show
    this green (see screenshot attached)
    ...not very important - just to understand what's going on.

    Bye, Felix

  3. Support Staff 3 Posted by Luke Le on 25 Jan, 2012 11:29 PM

    Luke Le's Avatar

    Hi Felix,

    actually this seems to be a bug of GPGMail.
    If you send an email through it, you should be able to also decrypt and read the email which is stored in your sent folder.

    The green indicator will be a default setting in the next version, for now you can enable it using

    Type the following command and press enter:

    defaults write org.gpgtools.gpgmail UseNonMonochromeEncryptionMethodHint -bool YES

    After running the command, please restart for the change to become effective.

    I know it's a very sensitive process, but if you'd be willing to have a quick screen sharing session using TeamViewer we might be able to solve your problem in a jiff.
    If we attempt the screen sharing session, It would be great if you could post or email me at [email blocked] your IM credentials (Skype, ICQ, AIM, ...)

  4. 4 Posted by felix on 26 Jan, 2012 12:39 AM

    felix's Avatar

    Hej Luke Le!
    Thanx - I got the green... ...I'm used to use the terminal. No problem. Thank you! If I can collect more information on my 'decrypt-my-own-messages'-problem I will post. But don't know when...

  5. Support Staff 5 Posted by Luke Le on 26 Jan, 2012 12:45 AM

    Luke Le's Avatar

    If you're comfortable with the command line I can instruct you on how to try to decrypt the mails manually.

    Could you also please post a screenshot of an error message you're seeing from GPGMail.

    After selecting a message you can't decrypt please follow these steps:

    1.) Use the Menubar and select "Darstellung" -> "E-Mail" -> "Reine Datei" (based on your email address I believe you're german :))
    2.) Copy the email content starting from "-----BEGIN PGP MESSAGE-----" till "-----END PGP MESSAGE-----"
    3.) Paste the copied pgp message into a text-file.
    4.) Run the following command in the Terminal

    gpg2 --decrypt --status-fd 1 pgp-message-filename

    5.) Post the output here (except of course the decrypted message, if it works from command line)

  6. 6 Posted by felix on 26 Jan, 2012 01:07 AM

    felix's Avatar

    here comes the output... ...ok...


    `spf-nb:~ spielvogel$ gpg2 --decrypt --status-fd 1 Documents/encrypted.txt
    [GNUPG:] ENC_TO 181647E167741D93 16 0
    [GNUPG:] ENC_TO B66E8A9DFDD39AF7 1 0
    gpg: verschlüsselt mit 4096-Bit RSA Schlüssel, ID FDD39AF7, erzeugt 2011-03-08
          "my name <my [email blocked]>"
    gpg: verschlüsselt mit 2048-Bit ELG Schlüssel, ID 67741D93, erzeugt 2004-04-23
          "recipients name <[email blocked]>"
    [GNUPG:] NO_SECKEY 181647E167741D93
    gpg: Entschlüsselung fehlgeschlagen: Kein geheimer Schlüssel


    I can explain something: gpgmail did grab an old key. I did have the question just 20 minutes ago: "wow does gpgmail know which key to use..." As far as I remember I did have to configure that as long as I was working on Snow Leopard.

  7. Support Staff 7 Posted by Luke Le on 26 Jan, 2012 01:12 AM

    Luke Le's Avatar

    That's exactly the problem.
    Before you could choose which key is used. At the moment this is no longer possible unfortunately, but I've already started working on that feature.
    What you can use as a workaround is to disable all keys which are connected to your email address which are no longer in use or remove any public keys connected to your email address which are no longer in use.
    Otherwise I'm sorry, but you'll have to wait for an upcoming version.

  8. 8 Posted by felix on 26 Jan, 2012 01:20 AM

    felix's Avatar

    Thanx a lot! I did just write an idea... ...same as you're talking about. As long as I know what to do I can go with it for some time!! (even if I like that "everything is always working" on my mac - almost ,-) )
    Good job - thanx again!

  9. Support Staff 9 Posted by Luke Le on 26 Jan, 2012 01:22 AM

    Luke Le's Avatar

    Hehe, it will be back to that soon! I promise :)

  10. 10 Posted by Alex on 04 Mar, 2012 11:11 PM

    Alex's Avatar

    Should work with - could you please verify?

  11. Support Staff 11 Posted by Steve on 18 Mar, 2012 09:11 PM

    Steve's Avatar

    No further user feedback. Closing for now.

    @Felix: Should your problem persist, feel free to open a new discussion and we'll be glad try to hunt down the bug and squash it for once and all. :)

    All the best, steve

  12. Steve closed this discussion on 18 Mar, 2012 09:11 PM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts


? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac