GPGMail: GPGKeychain: key generate error

Donald W Moore's Avatar

Donald W Moore

09 Apr, 2018 02:24 PM

Generate new key failed!
Code = 0
Error text:
gpg: lookup_hashtable failed: Unknown system error
gpg: trustdb: searching trust record failed: Unknown system error
gpg: Error: The trustdb is corrupted.
gpg: You may try to re-create the trustdb using the commands:
gpg: cd ~/.gnupg
gpg: gpg --export-ownertrust > otrust.tmp
gpg: rm trustdb.gpg
gpg: gpg --import-ownertrust < otrust.tmp

Expected
Tried running these commands in Terminal. Command not recognized. Was something not installed?

Additional info
Uninstalled and reinstalled GPG Suite twice. Same result.
MacOs High Sierra version 10.13.4 (17E199)

macOS                   10.13.4     17E199
GPG Suite               2018.1      2083    (9658b70)
GPGMail                 3.0b4       1272    (461cda15)
GPG Keychain            1.4.2       1403    (128637e)
GPGServices             1.11.2      969     (e5438f7)
MacGPG                  2.2.3       900     (cead4f9)
GPG Suite Preferences   2.1.1       993     (05eb1a6)
Libmacgpg               0.8.2       829     (943132e)
pinentry                0.9.7.1     9       (db18340)
  1. Support Staff 1 Posted by Luke Le on 19 Apr, 2018 01:32 PM

    Luke Le's Avatar

    Hi Donald,

    we are very sorry to hear that your are experiencing problems with GPG Suite. We have not yet heard of this problem before, but believe that running the commands to re-create the trustdb should in fact solve it.

    Following are the commands again to be run in Terminal:

        cd ~/.gnupg
        gpg --export-ownertrust > otrust.tmp
        rm trustdb.gpg
        gpg --import-ownertrust < otrust.tmp

    It‘s best if you copy and paste one command after the other.

    Hope that helps.

  2. 2 Posted by Donald W Moore on 19 Apr, 2018 03:50 PM

    Donald W Moore's Avatar

    Thanks, that did the trick. After running the terminal commands, GPG
    Keychain was populated with all the keys I had previously tried to generate.

    ________________
    Donald W. Moore
    Virginia Beach, VA.

  3. Support Staff 3 Posted by Steve on 19 Apr, 2018 04:21 PM

    Steve's Avatar

    Perfect. Glad, this is solved for you. I'm closing this discussion. Should you need further assistance or have questions you can re-open this discussion here or open a new one any time.

    Best,
    steve

  4. Steve closed this discussion on 19 Apr, 2018 04:21 PM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac