GPGMail: gpg: [stdin]: encryption failed: Unusable public key

Armin Zebrowski's Avatar

Armin Zebrowski

09 Apr, 2018 05:36 AM

Dear Service-Team:

Some of my pgp keys for different e-mail addresses had a limited validity and so I extended the validity using the gpg keychain app on my MacBook, and uploaded the extended keys to the key server. After updating the keys from the server on the iMac they show green symbols in the gpg app. Now I am in trouble as writing encrypted mails causes gpg to open a window with the following message:

gpg: 28FF34B9B29571EC819CE23DF8043C82898190EE: "ubersprungen: Unusable public key
gpg: [stdin]: encryption failed: Unusable public key

Should I now restart from the scratch with completely new keys? What can I do?

Thanks for any support.

I am currently working on an actual MacBookPro 15" (2017; macOS High Sierra 10.13.4) and an old iMac 27" (Mid 2010; macOS High Sierra 10.13.3).

Regards,

Armin

  1. Support Staff 1 Posted by Steve on 09 Apr, 2018 08:53 AM

    Steve's Avatar

    Hi Armin,

    welcome to the GPGTools support platform. Sorry you are having problems using GPG Suite.

    Let's check if your key is ok:

    1. open GPG Keychain
    2. double click your sec/pub key
    3. search for "Validity" in key tab and post the value to your discussion
    4. search for "Validity" in subkey tab and post the value to your discussion

    Should your key have expired, please re-new the expiration date in the key tab. To renew the subkey, click the cogwheel icon in the subkey tab and update the expiration date.

    To test the change, send a signed and encrypted test email to yourself. Are you able to decrypt and verify the signature successfully?

    In case your key resides on the public key servers, don't forget to upload your updated key, so that the changes are reflected there as well.

    Best regards,
    Steve

  2. 2 Posted by Armin on 09 Apr, 2018 09:10 AM

    Armin's Avatar

    Dear Steve:

    Thanks for your quick reply. Here is the requested information:

    Validity key tab:
    1. April 2019 um 09:23

    Validity subkey tab:
    31. März 2018 um 15:03

    Uhhh. By changing the validity in the key tab I did NOT change the validity in the subkey tab. I'll try again right away. Just a second.

    Uhh. It's getting worse. After changing the validity date in the key tab window I tried to upload the updated key. The software reported an error while trying to upload and seems to have lost contact to the key server. I will restart gpg now. Wait for further events!

    Well well, it doesn't show any keys any more at all, and I cannot update keys from the key server any more.

    Hmmmmmm.

    Doesn't work at all. I downloaded two keys now from two of my mail addresses. Trying to use them I receive the following error report:

    gpg: 86A41B8E5F3937122DB6B884D6EB2C250BCC946A: "ubersprungen: Unusable public key
    gpg: [stdin]: encryption failed: Unusable public key

    Hope you'll have just any idea. Thanks.

    Armin

  3. Support Staff 3 Posted by Steve on 18 Apr, 2018 05:10 PM

    Steve's Avatar

    Should you be available, could you hop on our live chat here:
    https://www.hipchat.com/gyyOrLdWt

    We can't promise a solution, but we'd like to inspect this problem in more detail. When joining the live chat, please post the URL of this discussion so we know which case you are contacting us about.

    All the best
    steve

  4. Support Staff 4 Posted by Steve on 18 Jul, 2018 02:24 PM

    Steve's Avatar

    Hi Armin,

    are you still seeing this problem using macOS 10.13.6 and GPG Suite 2018.3?

  5. 5 Posted by Armin Zebrowski on 20 Jul, 2018 07:20 AM

    Armin Zebrowski's Avatar

    Hi Steve,

    all troubles are gone currently. The solution was that I produced new key pairs – some of them seem to have been corrupted. Strange enough, don’t have any idea how that could happen, but it solved the problems.

    Thanks for following up, you’re a real professional!!!!

    Regards

    Armin

    Die Theosophische Gesellschaft Pasadena
    Armin Zebrowski
    Bohmreute 9
    D-71735 Eberdingen
    Germany

    Tel +49 (0)7042/78829
    Fax +49 (0)7042/78939
    Mobil +49 (0)163/8702901

    [email blocked]
    http://www.theosophie.de

Reply to this discussion

Internal reply

Formatting help / Preview (switch to plain text) No formatting (switch to Markdown)

Attaching KB article:

»

Attached Files

You can attach files up to 10MB

If you don't have an account yet, we need to confirm you're human and not a machine trying to post spam.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac