GPGMail: Unable to read messages, only a white block appears - fixed when gpg is plug-in disabled

acm.mobile's Avatar

acm.mobile

13 Mar, 2018 03:15 PM

I get new emails, or attempt to read sent emails, and all I get is an empty space. As if unable to load. If I disable the gpg plug-in it works, and then I tried re enabling to show the issue, but it apparently stops.

Is this a known bug? Any recommendation?

thanks!

Which of our tools is giving you problems?

GPG Mail for mac - suite version 2018.1, 2803, (9658b70)
GPGmail - 3.0b4, 1272, (461cda15)

  1. Support Staff 1 Posted by Steve on 17 Mar, 2018 03:40 PM

    Steve's Avatar

    Hi acm.mobile,

    could you please download and install our latest hotfix GPG Suite and see if that solves your problem.

    Also restart your mac and see if that changes anything for the better or worse.

    Are you using any additional plugins in Mail.app? Are all messages affected or only some?

    All the best,
    steve

    Disclaimer: This is a development version which has not been thoroughly tested yet - bugs or crashes are to be expected. Thanks for helping us test.

  2. 2 Posted by acm.mobile on 19 Mar, 2018 10:49 AM

    acm.mobile's Avatar

    Hi Steve,

    It seems to have solved it.

    Prior to installing it, most new emails that had pgp encryption would just show an empty blank space where the content should be, I’m guessing as it could not load the message.

    I do use another plug in, called mailbutler.

    At times I have this issue with older pgp emails from specific domains, but as I write this, I have tested them. The majority load with some random ones showing up with the wrong signature and thus unable to load. But fixed most.

    Thanks!

    Alfonso

  3. Support Staff 3 Posted by Steve on 19 Mar, 2018 11:17 AM

    Steve's Avatar

    Hi Alfonso,

    sounds much better. I am not sure I get the part about wrong signature emails and messages not loading. Do you mean the signatures are invalid? Or in what way are they wrong? Even messages with invalid signatures should load.

  4. 4 Posted by acm.mobile on 03 Apr, 2018 03:41 PM

    acm.mobile's Avatar

    Hi Steve,

    It seems this error comes back randomly, my mac mail will freeze at least twice a day and I have to force quit. When reopening the application, the messages I had on-screen reopen, and if they were encrypted, a white space will be there. To solve, I have to disable, quit, enable, quit, reopen, and this will be working again.

    I am beginning to wonder if there's an error being caused by another plugin I use, in conjunction will GPGtools - and regular mac mail crashing. The other plugin is called mail butler.

    Any recommendations on how to log and debug this?

    thanks,

  5. Support Staff 5 Posted by Steve on 04 Apr, 2018 11:02 PM

    Steve's Avatar

    There's three things you can do here to help us get to the root of this problem:

    1. temporarily disable Mail Butler and see if the issues still happens with only GPGMail installed

    2. temporarily disable GPGMail and see if the issue still happens with only Mail Butler installed

    3. Please create the following debug information:

    Spindump

    • open Activity Monitor
    • sort after 'Process Name' (first column) and select Mail
    • click the cogwheel icon and select 'Spindump'
    • 'Save...' the Spindump output to your desktop
    • attach the resulting file to your existing discussion

    Process Sample

    • open Activity Monitor
    • sort after 'Process Name' (first column) and select Mail
    • click the cogwheel icon and select 'Sample Process'
    • 'Save...' the Spindump output to your desktop
    • attach the resulting file to your existing discussion

    To temporarily disable GPGMail:

    • shut down mail.app
    • open finder
    • navigate to /Library/Mail/Bundles or ~/Library/Mail/Bundles and copy GPGMail.mailbundle to your desktop
    • now delete GPGMail.mailbundle from the original folder

    Restart mail and check in Mail.app > Preferences if you still see GPGMail. It should be gone.

    To re-enable mail, close Mail.app and move the bundle file back to the Bundles folder.

    Looking forward to your feedback.

  6. Support Staff 6 Posted by Steve on 18 Jul, 2018 02:12 PM

    Steve's Avatar

    Closing, since no further user feedback was received. Should your problem persist, feel free to re-open this discussion any time.

    All the best, steve

  7. Steve closed this discussion on 18 Jul, 2018 02:12 PM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac