GPGMail: Email signing doesn't work

Sander van de Graaf's Avatar

Sander van de Graaf

05 Mar, 2018 03:56 PM

Create email, activate signing, type email, click send. Receive error saying "gpg: signing failed: No secret key"

Expected
To have the email send

Additional info
gpg -K

/Users/svdgraaf/.gnupg/pubring.gpg

sec rsa4096 2016-08-16 [SC] [expires: 2032-08-12]
6738D7785BE1F90915D361A0F3739C0925F36E9F uid [ultimate] Sander van de Graaf [email blocked]
ssb rsa4096 2016-08-16 [E] [expires: 2032-08-12]
ssb rsa4096 2017-10-06 [E] [expires: 2021-10-06]

macOS                   10.13.3     17D47
GPG Suite               2018.1      2083    (9658b70)
GPGMail                 3.0b4       1272    (461cda15)
GPG Keychain            1.4.2       1403    (128637e)
GPGServices             1.11.2      969     (e5438f7)
MacGPG                  2.2.3       900     (cead4f9)
GPG Suite Preferences   2.1.1       993     (05eb1a6)
Libmacgpg               0.8.2       829     (943132e)
pinentry                0.9.7.1     9       (db18340)
  1. Support Staff 1 Posted by Steve on 05 Mar, 2018 04:28 PM

    Steve's Avatar

    Hi Sander,

    welcome to the GPGTools support platform. Sorry you are having problems using GPG Suite.

    The several subkeys with same capability in your key are intentional? If so, could you please download and install our latest latest hotfix GPG Suite and see if that solves your problem.

    There's at least one known issue in the current hotfix build so it's not recommended for productive use but it includes 2.2.5 which solves a problem in regards to subkey usage.

    All the best,
    steve

    Disclaimer: This is a development version which has not been thoroughly tested yet - bugs or crashes are to be expected. Thanks for helping us test.

  2. 2 Posted by Sander on 05 Mar, 2018 07:17 PM

    Sander's Avatar

    First of all, no worries, I think it's a neat service you are providing, so keep it up!

    I removed some of the subkeys, so now I only have one left. Unfortunately the hotfix doesn't fix the problem.

    While checking if I could find a debug log somewhere, I enabled debug logging. I figured I wanted to check the settings so far, and tried this:

    defaults read org.gpgtools.gpgmail
    2018-03-05 20:12:24.295 defaults[3512:51942]
    Domain org.gpgtools.gpgmail does not exist

    That doesn't seem right, I tried reinstalling (even with the regular build) but still the same issue. Not sure if that might be the actual problem...?

  3. 3 Posted by Sander on 05 Mar, 2018 07:44 PM

    Sander's Avatar

    I got it!

    It had nothing to do with the defaults, so whoever encounters the same issue in the future, that's not the issue.

    My problem was I had 2 different email accounts, and without me noticing, mail.app (new install) was defaulting to my -other- email address, which does have a gpg key but not a secret key attached to it (yubikey, which was not attached). So the error makes perfect sense, I just wasn't paying attention. Switching to the correct outgoing address made it work (doh!).

    Perhaps it would be nice to print the used identifier in the popup box somewhere so it's easier to spot in the future, something like:

    "gpg: signing failed: No secret key" for [email blocked]

    Or perhaps log the whole message to syslog when debugging is on.

    Anyway, thanks for the pointers! This ticket can be closed.
    Sander

  4. Support Staff 4 Posted by Steve on 06 Mar, 2018 02:57 PM

    Steve's Avatar

    Hi Sander,

    yeah the error message can surely be improved. We have a ticket for this problem. I connected this discussion with the existing ticket. That means, should this discussion get closed, it will be re-opened as soon as the ticket is closed. That way you'll stay in the loop and get notified as soon as we have news.

    Glad, this is solved for you. I'm closing this discussion. Should you need further assistance or have questions you can re-open this discussion here or open a new one any time.

    Best,
    steve

  5. Steve closed this discussion on 06 Mar, 2018 02:57 PM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac