GPGMail: Missing secret key for GPGSuite 2017.3?

Christian's Avatar

Christian

11 Jan, 2018 08:38 PM

Hi all!

Since the upgrade to (at least) 2017.3 I get a „missing secret key“ while trying to send a PGP signed and/or encrypted mail:

gpg: Beglaubigung fehlgeschlagen: No secret key
gpg: signing failed: No secret key

Thanks very much & best regards
cb

Expected
Sending signed / encrypted mail with secret key.

Additional info
A „gpg --import < ~/.gnupg/secring.gpg“ has already been issued…

macOS                   10.13.2     17C88
GPG Suite               2017.3      2081    (9658b70)
GPGMail                 3.0b3       1271    (4060831)
GPG Keychain            1.4.2       1403    (128637e)
GPGServices             1.11.2      969     (e5438f7)
MacGPG                  2.2.3       900     (cead4f9)
GPG Suite Preferences   2.1.1       993     (05eb1a6)
Libmacgpg               0.8.2       829     (943132e)
pinentry                0.9.7.1     9       (db18340)
  1. Support Staff 1 Posted by Steve on 17 Jan, 2018 07:28 PM

    Steve's Avatar

    Hi Christian,

    welcome to the GPGTools support platform. Sorry you are having problems using GPG Suite.

    Could you please download and install our latest GPG Suite nightly build.

    Please also do restart your mac and let us know if after that you are still getting the same error message.

    Your key looks fine in a brief check so the error feels rather wrong indeed.

    All the best,
    steve

    Disclaimer: This is a development version which has not been thoroughly tested yet - bugs or crashes are to be expected. Thanks for helping us test.

  2. 2 Posted by Christian on 17 Jan, 2018 09:23 PM

    Christian's Avatar

    Hi Steve!

    Thanks for your reply! Unfortunately after installing the nightly build and restarting my Mac, I still got the same error message when I try to send the mail.

    Should I deinstall GPG completely!?

    Thanks once again & kind regards
    cb

  3. Support Staff 3 Posted by Luke Le on 18 Jan, 2018 11:03 AM

    Luke Le's Avatar

    Hi Christian,

    laut GnuPG wird dein Signing sub key nicht gefunden. Dafür kann es mehrere Ursachen geben, in einigen Fällen liegt es daran, dass eine Smart Card zu einem Zeitpunkt im Einsatz war.
    In manchen Fällen, war es aber auch so, dass der User den Key auf mehreren Rechnern im Einsatz hatte. Auf einem Rechner einen Subkey hinzugefügt hat, aber auf den anderen den dann nie importiert hat.
    Könnte einer der beiden Fällen auf dich zutreffen?

    Um das Problem zu lösen, mach am besten ein Backup deines Keys, und lösch dann den Signing subkey (sieht du in GPG Keychain)

  4. Support Staff 4 Posted by Steve on 26 Mar, 2018 06:57 PM

    Steve's Avatar

    Da wir kein Feedback mehr erhalten haben, schließen wir diese Diskussion. Sollten dein Problem fortbestehen, kannst du diese Diskussion jederzeit wieder öffnen.

    Viele Grüße,
    steve

  5. Steve closed this discussion on 26 Mar, 2018 06:57 PM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac