GPGMail: Inline Signed Mails only shown as signed after a restart of Mail.app

tanzblume's Avatar

tanzblume

17 Nov, 2017 01:54 AM

If there is an inline signed mail, like Mircrosoft security notification, the mail will marked as signed only after mail restart.

Expected
It should be marked as signed at the moment I read the mail the first time

macOS           10.13.2     17C79a
GPG Suite       2017.1      2002    (4161887)
GPGMail         3.0b1       1244    (7f051cc)
GPG Keychain    1.4         1377    (3384573)
GPGServices     1.11.1      961     (d6060fa)
MacGPG2         2.2.0       893     (ab15b08)
GPGPreferences  2.1         977     (b1e419a)
Libmacgpg       0.8         819     (c8cf2e0)
pinentry        0.9.7       6       (6aeb033)
  1. Support Staff 1 Posted by Steve on 22 Nov, 2017 10:27 PM

    Steve's Avatar

    Hi tanzblume,

    could you please download and install our latest GPG Suite nightly build and see if the problem persists. That page also has sig and SHA256 to verify the download.

    In case the problem persists, could you export the message in question, so that we can have a closer look. To export, simply select the message in Mail.app and press CMD + SHIFT + S, select "Raw Message Source" as type and save it.

    Attach the resulting .eml file to this discussion by visiting it in your browser (email reply should work but sometimes attachments do not arrive).

    All the best,
    steve

    Disclaimer: This is a development version which has not been thoroughly tested yet - bugs or crashes are to be expected. Thanks for helping us test.

  2. 2 Posted by tanzblume on 23 Nov, 2017 07:32 AM

    tanzblume's Avatar

    I had installed the nightly build. Now I'm waiting for Microsofts newsletter with inline signature.
    I can tell you, that one other problem is gone with this build.
    In version 3.0b1 (1244) GPGMail had problems to find public keys in my keychain. That problem is gone.

  3. Support Staff 3 Posted by Steve on 23 Nov, 2017 09:36 AM

    Steve's Avatar

    There was a problem with the key server check which was fixed in nightly. That may have been what you were running into.

    OK, let's wait for the next Microsoft email to arrive. If the issue persists, please share the eml file if possible and we'll take a closer look.

    Have a great day,
    steve

  4. 4 Posted by tanzblume on 07 Dec, 2017 07:51 AM

    tanzblume's Avatar

    Hi Steve,
    yesterday you released a new version of GPGtools.
    Also I received a new inline signed mail from Microsoft.
    Now it works like it should.

    Thank you

  5. Support Staff 5 Posted by Steve on 07 Dec, 2017 10:21 PM

    Steve's Avatar

    That's great news.

    Glad, this is solved for you. I'm closing this discussion. Should you need further assistance or have questions you can re-open this discussion here or open a new one any time.

    Best,
    steve

  6. Steve closed this discussion on 07 Dec, 2017 10:21 PM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac