GPGMail: Option to disable auto-decryption

Tobias's Avatar

Tobias

15 Nov, 2017 08:53 AM

First off, thank you kindly for developing GPG Suite. It is without a doubt the best GPG frontend I've ever used—it being open source is the icing on this delicious crypto-cake.

I keep my PGP key on a smartcard. An unfortunate side-effect is that, whenever I view a chain of emails in Mail.app, I get a prompt to insert my smartcard for every single message encrypted with my public key. This gets really annoying when you're browsing through your mail archive without wanting to decrypt any messages.

Perhaps you could add an option to disable automatic decryption of emails and a little button to manually decrypt them?

  1. Support Staff 1 Posted by Steve on 23 Nov, 2017 12:15 AM

    Steve's Avatar

    Hi Tobias,

    welcome to the GPGTools support platform. Sorry you are having problems using GPG Suite.

    If storing the password for your OpenPGP key in macOS keychain is an option, you could try that, as it may get rid of the prompts you are seeing.

    We have not tested this, but think it may be worth giving it a try. Please see this KB-article on how to manage passwords for your keys.

    Let us know what you think.

    All the best,
    steve

  2. 2 Posted by Tobias on 23 Nov, 2017 10:53 AM

    Tobias's Avatar

    No Steve, that doesn't solve the problem I described. I'm honestly not sure if you actually read my initial post. Please read it again carefully. Passphrases have nothing to do with this. When my smartcard is not inserted into my MacBook, GPGTools prompts me to insert it in order to view encrypted mail messages. This is what I would like to suppress, because viewing a thread of encrypted messages in Mail.app shows a prompt for every single encrypted message in that thread. Once the first prompt has displayed, you have to click cancel once for every encrypted message in the thread, which is frustrating, cumbersome and a waste of time.

    I wanted to test what you suggested, but I found that option to be enabled already. It has no effect on my problem.

    If you have a smartcard available to you, please try to reproduce this problem, you'll see what I'm talking about.

  3. Support Staff 3 Posted by Steve on 23 Nov, 2017 10:58 AM

    Steve's Avatar

    I do not have a smartcard. As mentioned we will be able to test this the upcoming week.

    Can you attach a screenshot of the prompt you are seeing to insert your smartcard please.

  4. 4 Posted by Tobias on 23 Nov, 2017 11:01 AM

    Tobias's Avatar

    Here's a screenshot of the prompt.

  5. Support Staff 5 Posted by Luke Le on 14 Dec, 2017 12:43 PM

    Luke Le's Avatar

    Hi Tobias,

    thank you for your patience.
    We have created a ticket for your problem. Unfortunately it is very hard in Mail to distinguish between if one message or more than one message was selected, at the point where the decryption occurs. We have been looking into that again and again over the years, but have yet to find a satisfying solution.
    While disabling automatic decryption is certainly an option, it is far from ideal. It will take us a little longer to figure this out.

    You will be automatically notified, if we make progress on the connected ticket.

    Should the discussion be closed in the meantime, it will be re-opened once we have a solution for the issue.

Reply to this discussion

Internal reply

Formatting help / Preview (switch to plain text) No formatting (switch to Markdown)

Attaching KB article:

»

Attached Files

You can attach files up to 10MB

If you don't have an account yet, we need to confirm you're human and not a machine trying to post spam.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac