Not connecting to SKS Keystore

Aaron's Avatar

Aaron

27 Sep, 2017 10:05 AM

Hi Guys,

Im having issues with GPG Suite v1.4 connecting to a sks keystore. Version 1.3.3b2 (1271b) seems to work fine. When I try to connect to the keystore with the 1.4 application it responds with a "Bad Server' error. Has any one else had the same issue? Any ideas of how I can fix it?

The server is running sks version 1.5

Thanks

Aaron

  1. Support Staff 1 Posted by Steve on 27 Sep, 2017 11:41 AM

    Steve's Avatar

    Hi ,

    welcome to the GPGTools support platform. Sorry you are having problems using GPG Suite.

    Can you post the key server URL you are using? Find that in GPG Keychain > Preferences > Key server

    Are you behind a firewall or using any blocking software?

    Best,
    steve

  2. 2 Posted by shiggles-aaron on 27 Sep, 2017 12:23 PM

    shiggles-aaron's Avatar

    Hi steve, the server itself is behind a firewall batted from a public address to a private one, ports 11370-11372 are allowed from anywhere for testing purposes. No block on outbound traffic

    Thanks

    Aaron

    Sent from my iPhone

  3. Support Staff 3 Posted by Luke Le on 27 Sep, 2017 12:34 PM

    Luke Le's Avatar

    Hi Aaron,

    would it be possible to send us the address of the keyserver?
    It's possible this is related to a certificate error, but if we know the keyserver we can have a more detailed look into your problems.

  4. 4 Posted by shiggles-aaron on 27 Sep, 2017 12:36 PM

    shiggles-aaron's Avatar

    There is currently no certificate installed and is only responding on 11371.

    URL is keys.shiggles.co.uk:11371

    Appreciate the help :)

    Sent from my iPhone

  5. 5 Posted by shiggles-aaron on 27 Sep, 2017 04:00 PM

    shiggles-aaron's Avatar

    Don't worry guys

    I have well and truly broken the server now. Ill try and rebuild it and see if it works - will keep you posted

    Thanks

    Aaron

    Sent from my iPhone

  6. Support Staff 6 Posted by Luke Le on 27 Sep, 2017 04:12 PM

    Luke Le's Avatar

    Hi Aaron,

    sorry I was about to write a response.
    No need to rebuild, you simply have to add the keyserver manually at the moment.

    You can do this by editing your gpg.conf file (in ~/.gnupg) and adding the following line:

    keyserver hkp://keys.shiggles.co.uk:11371

    And remove any other keyserver lines
    After that it should work.

    We're about to add a ticket to improve our check for valid key servers. Yours resulted in an error even though it's working properly.

  7. 7 Posted by shiggles-aaron on 27 Sep, 2017 04:48 PM

    shiggles-aaron's Avatar

    Luke

    Thanks for your reply, will give it a go and let you know how it goes

    Many thanks

    Aaron

    Sent from my iPhone

  8. 8 Posted by shiggles-aaron on 27 Sep, 2017 04:56 PM

    shiggles-aaron's Avatar

    Luke,

    I updated the gpg suite to v1.4 (which others are using) and edited the file as suggested.

    This has made no difference I still get the error message 'Bad Key Server'

    Thanks

    Aaron

    Sent from my iPhone

  9. Support Staff 9 Posted by Steve on 27 Sep, 2017 10:55 PM

    Steve's Avatar

    Aaron, could you please send a debug log from your affected machine: Open System Preferences > GPGPreferences / GPG Suite > Send Report. Check the box to "attach debug log". Since you already described your issue in this discussion, you don't need to add a lot of detail, but please do add the link to your existing discussion, so I can then merge your debug info with this existing discussion.

    All the best,
    steve

  10. 10 Posted by Aaron Corbin on 28 Sep, 2017 07:43 AM

    Aaron Corbin's Avatar

    Hi Steve,

    Debug report is on its way

    Thanks,

    Aaron

  11. Support Staff 11 Posted by Steve on 28 Sep, 2017 10:54 AM

    Steve's Avatar

    And arrived.

    Moving to pending. We'll get back to you about this.

  12. 12 Posted by shiggles-aaron on 28 Sep, 2017 11:09 AM

    shiggles-aaron's Avatar

    Steve,

    Just to confirm I have sent over two debug logs, the first was for v1.3 which is the one that works, the second was with v1.4 which does not

    Thanks

    Aaron

    Sent from my iPhone

  13. Support Staff 13 Posted by Steve on 28 Sep, 2017 12:01 PM

    Steve's Avatar

    Updated, thx for the hint.

  14. Support Staff 14 Posted by Steve on 13 Oct, 2017 01:49 PM

    Steve's Avatar

    Hi Aaron,

    we've fixed some things around the key server check.

    Could you please download and install our latest GPG Suite nightly build and see if the problem persists. That page also has sig and SHA256 to verify the download.

    All the best,
    steve

    Disclaimer: This is a development version which has not been thoroughly tested yet - bugs or crashes are to be expected. Thanks for helping us test.

  15. 15 Posted by Aaron Corbin on 13 Oct, 2017 03:43 PM

    Aaron Corbin's Avatar

    Thanks Steve,

    I won’t be around to do this until Monday at the earliest but will let you know how I get on.

    Many thanks

    Aaron

    Sent from my iPhone

  16. 16 Posted by Aaron Corbin on 17 Oct, 2017 10:27 AM

    Aaron Corbin's Avatar

    Steve,

    That seems to have fixed the issue!

    Many thanks for your help on this one!

    Best wishes,

    Aaron

  17. Support Staff 17 Posted by Steve on 18 Oct, 2017 04:30 PM

    Steve's Avatar

    Perfect. Glad, this is solved for you. I'm closing this discussion. Should you need further assistance or have questions you can re-open this discussion here or open a new one any time.

    Best, steve

  18. Steve closed this discussion on 18 Oct, 2017 04:30 PM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac