GPG Keychain: Update to GPG Suite 2017.1b3 deleted all my keys

ffittschen's Avatar

ffittschen

24 Aug, 2017 08:12 AM

Hi there, as stated above, the update to 2017.1b3 deleted all my keys. I already tried solutions from other discussions: restart the Mac, export the keys via terminal and install the old version again.

Nothing helped to bring the keys back.

Expected
Install 2017.1b3 over 2016.10 does not remove the keys.

macOS           10.12.6     16G29
GPG Suite       2016.10     21  
GPGMail -
GPG Keychain    1.3.2       1245
GPGServices     1.11        916 
MacGPG2         2.0.30      884 
GPGPreferences  2.0.1       902 
Libmacgpg       0.7         775 
pinentry        0.9.7       4
  1. Support Staff 1 Posted by Steve on 25 Aug, 2017 12:05 PM

    Steve's Avatar

    Hi ffittschen,

    welcome to the GPGTools support platform. Sorry you are having problems using GPG Suite.

    What makes you think, the keys have been deleted? Could you provide a screenshot or two and describe in more detail what you are looking at?

    All the best,
    steve

  2. 2 Posted by ffittschen on 25 Aug, 2017 07:35 PM

    ffittschen's Avatar

    Hi Steve,

    I am looking at the GPG Keychain window, which just displays the GPGTools Team public key and nothing else (see screenshot).

    Before the update, I could see my own private + public key and other public keys I used previously.

    Best regards,
    Florian

  3. Support Staff 3 Posted by Steve on 25 Aug, 2017 08:30 PM

    Steve's Avatar

    Should you be available, could you hop on our live chat here:
    https://www.hipchat.com/gyyOrLdWt

    We can't promise a solution, but we'd like to inspect this problem in more detail.

    All the best
    steve

  4. Support Staff 4 Posted by Steve on 25 Aug, 2017 09:31 PM

    Steve's Avatar

    Could you please download and install our latest GPG Suite nightly build and see if the problem persists. That page also has sig and SHA256 to verify the download.

    All the best,
    steve

    Disclaimer: This is a development version which has not been thoroughly tested yet - bugs or crashes are to be expected. Thanks for helping us test.

  5. Support Staff 5 Posted by Steve on 25 Aug, 2017 09:32 PM

    Steve's Avatar

    If after installing the nightly build you are still not seeing your keys, please do the following:

    • open Terminal.app
    • paste the following command ls -l ~/.gnupg
    • press enter
    • copy the output to this discussion here
  6. Support Staff 6 Posted by Steve on 18 Oct, 2017 02:31 PM

    Steve's Avatar

    Is your problem persisting? Have you updated to GPG Suite 2017.1?

    Could you sned the terminal output in case your problem persists?

  7. Support Staff 7 Posted by Steve on 22 Nov, 2017 12:02 PM

    Steve's Avatar

    Closing, since no further user feedback was received. Should your problem persist, feel free to re-open this discussion any time.

    All the best, steve

  8. Steve closed this discussion on 22 Nov, 2017 12:02 PM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac