Can not decrypt after updating from 10.11 to 10.12

leeharvey's Avatar

leeharvey

17 Aug, 2017 09:42 AM

Hello, after changing the operating system from mac os el capitan to mac os sierra, I can no longer use the encryption and decryption functions. In GPG keychain (Version 1.3.3b2 (1271b) my private and public key is still present. I have re-installed gpg tools but the problem persists.
Thank you for your help!

  1. Support Staff 1 Posted by Steve on 17 Aug, 2017 10:13 AM

    Steve's Avatar

    Hi Lee,

    welcome to the GPGTools support platform. Sorry you are having problems using GPG Suite.

    We currently offer GPG Suite 2016.10 (stable) and GPG Suite 2017.1 (beta). GPGMail for macOS 10.12 Sierra is in beta. To switch to the beta channel:

    1. open GPGPreferences > Settings
    2. in the Update section tick the checkbox to 'Include beta builds'
    3. optionally also enable automatic update checks, to ensure you are notified about new beta releases
    4. press 'Check Now'

    After that GPGMail should be up and running again.

    If you see any trouble using the beta, please let us know.

    All the best,
    steve

  2. 2 Posted by leeharvey on 17 Aug, 2017 12:21 PM

    leeharvey's Avatar

    Thanks Steve for your reply. But I have already downloaded the beta version and in the preferences settings everything is as you say. The problem is that when I want to encrypt a text I type on my keyboard the shortened it produces a beep and the text is not encrypted. Same to decrypt. As you see in my screenshot the recounts are filled correctly. I can not find what is wrong

  3. Support Staff 3 Posted by Steve on 17 Aug, 2017 12:24 PM

    Steve's Avatar

    The screenshot you show is only the file settings. There is another section regarding text. Could you attach another screenshot for those settings as well please.

  4. 4 Posted by leeharvey on 17 Aug, 2017 12:30 PM

    leeharvey's Avatar

    This one ?

  5. Support Staff 5 Posted by Steve on 17 Aug, 2017 12:34 PM

    Steve's Avatar

    Should you be available, could you hop on our live chat here:
    https://www.hipchat.com/gyyOrLdWt

    We can't promise a solution, but we'd like to inspect this problem in more detail.

    All the best
    steve

  6. 6 Posted by leeharvey on 17 Aug, 2017 12:57 PM

    leeharvey's Avatar

    Okay Steve i Will contact you tomorrow morning on the chat

    Sent from ProtonMail Mobile

    On jeu., août 17, 2017 at 2:34 PM, Steve <[email blocked]> wrote:

  7. Support Staff 7 Posted by Steve on 17 Aug, 2017 01:25 PM

    Steve's Avatar

    If that's not possible, can you please test the following:

    1. Are you able to send yourself an encrypted and signed email and decrypt and verify that message upon reception?

    2. Let's test gpg encryption and decryption in the terminal.

    3. click spotlight at the top right menubar and type 'terminal'

    4. open Terminal.app by pressing enter

    5. in the new terminal window

    6. paste the following without the ' 'gpg2 -ae --default-recipient-self <<<OK'

    7. a PGP message will be created

    8. paste the following without the ' 'gpg2 -ae --default-recipient-self <<<OK | gpg2 -d'

    9. you will be asked for your password (if your password is still in the cache or stored in macOS keychain you will not be asked)

    10. when everything is fine you should see the word "OK" in your terminal - in that case decryption worked as expected

    We'll go from there.

  8. 8 Posted by leeharvey on 17 Aug, 2017 10:31 PM

    leeharvey's Avatar

    I followed step by step this procedure on the terminal. It was successful. I had the word Ok at the end.

    but my problem is still the same, when i typed the shortcut on my keyboard to encrypt it doesn't work :(

  9. Support Staff 9 Posted by Steve on 18 Aug, 2017 08:36 AM

    Steve's Avatar

    OK, so now we know your key is fine and the OpenPGP setup on your machine works as expected.

    Have you also tried sending an encrypted and signed mail to yourself?

    Could you now try encrypting and decrypting some sample text in TextEdit without using any keyboard shortcuts, but using the GPGServices Services options. Does that work?

  10. 10 Posted by leeharvey on 18 Aug, 2017 02:11 PM

    leeharvey's Avatar

    Hi Steve,

    After updating It works using GPG service option. But using keyboard shortcuts it doesn't work. Thank you for your help.

    Sent from ProtonMail Mobile

    On ven., août 18, 2017 at 10:36 AM, Steve <[email blocked]> wrote:

  11. Support Staff 11 Posted by Steve on 18 Aug, 2017 02:28 PM

    Steve's Avatar

    That's great news. It's good to know that after the macOS update GPGServices do behave correctly to begin with.

    Regarding the keyboard shortcuts: I am not 100% sure about those. You would define them in System Preferences > Keyboard > Service (the location we looked at earlier).

    But there may be existing conflicting shortcuts. I am not sure if there is a tool to double check that or how macOS deals with that.

Reply to this discussion

Internal reply

Formatting help / Preview (switch to plain text) No formatting (switch to Markdown)

Attaching KB article:

»

Attached Files

You can attach files up to 10MB

If you don't have an account yet, we need to confirm you're human and not a machine trying to post spam.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac