GPG installation hangs while running package script

Miheer's Avatar

Miheer

12 May, 2017 05:08 PM

I am on macOS 10.12.4. Installation is stuck here for 15-20 minutes.

  1. 1 Posted by Miheer on 13 May, 2017 02:51 PM

    Miheer's Avatar

    The installation successfully ended. But another installer for an unrelated software was also stuck at "running package scripts" for a long time. Perhaps there is an issue with my system.

  2. Support Staff 2 Posted by Steve on 15 May, 2017 11:51 AM

    Steve's Avatar

    Hi Miheer,

    welcome to the GPGTools support platform. Sorry you are having problems using GPG Suite.

    Could you re-install GPG Suite? No information will be lost - and see if the problem can be reproduced every time.

    All the best,
    steve

  3. 3 Posted by Steve on 19 May, 2017 03:03 PM

    Steve's Avatar

    Are there any thoughts on this problem?

    I'm having a nearly identical experience (install is hanging in exactly the same place in the install timeline), except that it's still hanging for over an hour as of this writing.

  4. Support Staff 4 Posted by Steve on 19 May, 2017 08:39 PM

    Steve's Avatar

    Steve, which exact macOS version are you on?

    Have you re-downloaded GPG Suite and tried to re-install that?

  5. 5 Posted by Miheer on 19 May, 2017 08:54 PM

    Miheer's Avatar

    I tried reinstalling (the beta version this time). The problem persists.

  6. Support Staff 6 Posted by Steve on 19 May, 2017 08:59 PM

    Steve's Avatar

    @Miheer

    Should you be available, could you hop on our live chat here:
    https://www.hipchat.com/gyyOrLdWt

  7. Support Staff 7 Posted by Steve on 19 May, 2017 09:29 PM

    Steve's Avatar

    The problem at hand is caused by a bug in macOS. It already exists in Apples bug tracking system and is bug #24637789. We reported this problem in April 2016 and our report #25903636 was set to duplicate state of bug #24637789 so the issue was known prior to our report.

    Please use their feedback form to inform Apple about this problem and ask them kindly to consider investing the time to fix this bug. It may help to add the bug number, so they know which issue you are referring to.

    If the issue is persisting for you, please provide a system diagnostic (run /usr/bin/sysdiagnose in Terminal) during or immediately after the problem occurs. Attach the resulting file to this discussion. We will then forward that information to Apple.

Reply to this discussion

Internal reply

Formatting help / Preview (switch to plain text) No formatting (switch to Markdown)

Attaching KB article:

»

Already uploaded files

  • Screen_Shot_2017-05-12_at_1.06.21_PM.png 264 KB

Attached Files

You can attach files up to 10MB

If you don't have an account yet, we need to confirm you're human and not a machine trying to post spam.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac