GPGMail: Can't open any Mails

Fabian's Avatar

Fabian

02 Feb, 2017 09:29 AM

Unfortunatly, the newest BETA I got, still blocks all viewing of encrypted OR non-encrypted Emails.

Open Mail Client - click on any Email - Email Window will not show any contents, but only the „Loading Wheel“.

Expected
Can’t use GPG Beta for testing, because it’s making my Mail Client unusable. No Emails, encrypted OR non-encrypted, can be viewed.

macOS           10.12.2     16C67
GPG Suite       2017.1b2    31b 
GPGMail         2.7b2       1192b
GPG Keychain    1.3.3b1     1249b
GPGServices     1.11        916 
MacGPG2         2.0.30-1b2  887-
GPGPreferences  2.0.2b2     912b
Libmacgpg       0.7         775 
pinentry        0.9.7       4
  1. Support Staff 1 Posted by Steve on 02 Feb, 2017 09:20 PM

    Steve's Avatar

    Hey Fabian,

    thanks for your report.

    Could you temporarily disable GPGMail:

    • shut down mail.app
    • open finder
    • navigate to /Library/Mail/Bundles or ~/Library/Mail/Bundles and copy GPGMail.mailbundle to your desktop
    • now delete GPGMail.mailbundle from the original folder

    Restart mail and check in Mail.app > Preferences if you still see GPGMail. It should be gone.

    To re-enable mail, close Mail.app and move the bundle file back to the Bundles folder.

    How does mail.app behave without GPGMail? And what happens if you add it back?

    Also can you please try to find a pattern of affected messages. Are all affected messages unencrypted and unsigned? Or are some of them encrypted?

    All the best,
    steve

  2. 2 Posted by Fabian Uitz on 03 Feb, 2017 06:18 PM

    Fabian Uitz's Avatar

    Hi Steve

    Thanks for your tipps.

    I was able to delete the 2nd Beta as described. Mail App works fine and as usual without it.

    I now went back to the 2016 version, which displays all non-ecrypted mails fine. Encrypted mails are not displayed, but can be viewed through the services-menu work around (=right click-decrypt manually-show in new window….)

    I can’t determine any pattern precisely. When I installed the 2nd BETA the first time, it decrypted the first mail right away without any problems. After trying to open older encrpted Mails, it stopped working.

    Theories:
    I feel that all NEW INCOMING ENCRYPTED Mail can’t be decrypted, I only see the Loading-Wheel.
    ALL Non-ecrypted Mail, that has been viewed before or is saved locally or in cache, seems to be working and can be viewed.

    Ill send more reports to you, as soon as I can observe more precise patterns.

    THX for the work!
    F

  3. 3 Posted by Håvard on 03 Feb, 2017 06:44 PM

    Håvard's Avatar

    I had the same problem as Fabian describes after installing the GPG Suite 2017.1b2 for Mac OS Sierra. Emails headers arrive in the client, but the content doesn't show, only the 'loading' message. Only had unencrypted and unsigned emails at the time. Moreover, trying to close Mail.app with cmd-q when this happens doesn't work, had to kill it from the terminal.

    Removing the mailbundle file fixed the problem, but no GPG then :-(

  4. Support Staff 4 Posted by Steve on 19 Feb, 2017 05:32 PM

    Steve's Avatar

    Hey all,

    we are working on this exact problem and hope to have a solution soon. As always we'll let you know via this discussion as we have news.

    Once you see the bug you describe, mail.app becomes unresponsive and you need to force quit and restart mail.app.

    Best,
    steve

  5. Support Staff 5 Posted by Steve on 10 Mar, 2017 12:40 AM

    Steve's Avatar

    Hi Fabian and Håvard,

    this issue has been fixed in our latest nightly GPG Suite. That page also has sig and SHA265 to verify the download.

    It would be awesome if you could install that nightly build and let us know, if it solves the "Loading..." issue for you.

    Looking forward to your feedback,
    steve

    Disclaimer: This is a development version which has not been thoroughly tested yet, so bugs or crashes are to be expected. Thanks for helping us test this fix.

  6. 6 Posted by Fabian Uitz on 10 Mar, 2017 11:23 AM

    Fabian Uitz's Avatar

    Dear Steve,

    I installed the new release and will test it the next view days. So far it works like a charm, but I had to do a full reboot, after it didn't work first quite smoothly with older encrypted Mails. After the reboot, the old encrypted mails decrypt perfectly aswell.

    Ill let u know if I’m having issues and I thank you VERY VERY MUCH! Donations will come.

    F

  7. Support Staff 7 Posted by Steve on 10 Mar, 2017 11:24 AM

    Steve's Avatar

    Thanks for the feedback. The problem with this bug is, it is hard to reproduce reliably. So please observe for a few days how things behave and let us know.

    Have a great day

  8. 8 Posted by Fabian Uitz on 12 Mar, 2017 10:27 PM

    Fabian Uitz's Avatar

    Hi Steve,

    Here are some troubles I’m heaving with the release u sent me the other day:

    I saved an Email, before I installed GPG Tools, cause I wanted to send it later. After I installed GPG Tools, Mail App crashed completely when I tried to open any Saved Mails - force quit.
    I can open and decrypt 1 or 2 emails after starting Mail app. When selecting a 3rd or 4th Email, no matter if encrypted or non-encrypted, Mail App stopps working - force quit.
    At the end, I wanted to start clean, so I deleted everything from /Library/Mail/Bundles, when I noticed something:

    Before I deleted the mailbundle, I used the latest nightly GPG Suite release and encrypted an Email. I didn’t send it. I just saved it. Then, after everything crashed again and deleting the Mailbundle, I opened Mail App and, offcourse, I couldn’t decrypt the Mail because it was encrypted and the plugin was not installed anymore. I opened the saved Mail from before, and hit „send“. After that, I installed the latest nightly GPG Suite again, and I was able to Decrypt the same Email from my „Sent“ folder with out any problems. So Encryption works, but the Mail App keeps crashing when I try to do it more than 2 or 3 times in a row.

    so far my experiences.

    greetings
    f

  9. 9 Posted by Håvard Raddum on 13 Mar, 2017 07:49 AM

    Håvard Raddum's Avatar

    Hi,

    Now I have got around to reinstall the GPG you linked to. So far I have only sent two encrypted and signed emails, and it seems to work fine. I’ll let you know if I run into any trouble.

    Håvard

  10. 10 Posted by Håvard Raddum on 13 Mar, 2017 10:42 AM

    Håvard Raddum's Avatar

    Now I ran into trouble. A few hours after installing the GPG the Mail app stopped receiving new emails, and would not show older emails that were not cached locally, only "Loading...."

  11. Support Staff 11 Posted by Steve on 13 Mar, 2017 11:59 AM

    Steve's Avatar

    Thanks for the feedback. Sadly, this issue is not fully fixed yet. We'll update you with a new build as soon as a new build addressing this problem will be available.

  12. Support Staff 12 Posted by Steve on 19 Mar, 2017 11:50 PM

    Steve's Avatar

    Hi Fabian,

    we believe this issue has been fixed. If you want to test the fix, please download our latest nightly GPG Suite. That page also has sig and SHA1 to verify the download.

    It would be great if you have time on your hands, to provide feedback on this, since we are in the midst of preparing the next beta and we'd love to check with affected users, that the issue is indeed fixed.

    Looking forward to your feedback.

    Kindly,
    steve

    Disclaimer: This is a development version which has not been thoroughly tested yet, so bugs or crashes are to be expected. Thanks for helping us test this fix.

  13. 13 Posted by Fabian Uitz on 20 Mar, 2017 08:08 AM

    Fabian Uitz's Avatar

    I will steve, ill test it maybe today and definitely tomorrow. Im out of office a lot right now. Im glad u are behind this so much.

    Fabian

  14. 14 Posted by Fabian Uitz on 20 Mar, 2017 10:49 AM

    Fabian Uitz's Avatar

    Dear Steve,

    FEEDBACK:
    Looking good, looking good. So far, the Problem with the „loading wheel“ issue, that appeared after opening 2 or 3 mails, has NOT occured. No crashes and no delays when trying to open emails of any kind.

    One new minor issue came up:

    I tested the 20-03 release by sending out encrypted Mails to friends, asking wether they could read/decrypt them or not. But whenever I hit send, I get an ERROR MESSAGE POP-UP that says: „I cant encrypt this message, because I don't have the necessary Public Key". That happened with every recipient I tried, even with my own Email Adress. BUT: all emails seem to be encrypted just fine and my Pub keys are being used. My friends can read and decrypt the mails. So I think the Error message is a bug….

    Good day,
    F

    > Am 20.03.2017 um 09:08 schrieb Fabian Uitz <[email blocked]>:
    >
    > I will steve, ill test it maybe today and definitely tomorrow. Im out of office a lot right now. Im glad u are behind this so much.
    >
    > Fabian
    >
    >> Am 20.03.2017 um 00:50 schrieb Steve <[email blocked]>:
    >>

  15. Support Staff 15 Posted by Steve on 20 Mar, 2017 03:24 PM

    Steve's Avatar

    Thanks for the feedback Fabian.

    We are already working on that regression, which slipped in.

    We have a ticket for this problem. I connected this discussion with the existing ticket. That means, should this discussion get closed, it will be re-opened as soon as the ticket is closed. That way you'll stay in the loop and get notified as soon as we have news. Feel free to open a new discussions should you run into further problems or need assistance.

  16. Steve closed this discussion on 20 Mar, 2017 08:42 PM.

  17. Support Staff 16 Posted by Steve on 22 Mar, 2017 09:40 PM

    Steve's Avatar

    Hey Fabian,

    GPG Suite 2017.1b3 has just been released. Could you please update to the new release and let us know if your problem persists using the latest beta.

    All the best,
    steve

  18. 17 Posted by Fabian Uitz on 22 Mar, 2017 10:09 PM

    Fabian Uitz's Avatar

    hi steve

    thank u, issue is gone!

    great release!!!

  19. Support Staff 18 Posted by Steve on 22 Mar, 2017 10:12 PM

    Steve's Avatar

    Perfect. Glad, this is solved for you. I'm closing this discussion. Should you need further assistance or have questions you can re-open this discussion here or open a new one any time.

    Best, steve

  20. Steve closed this discussion on 22 Mar, 2017 10:12 PM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac