rarely able to get encryption/decryption to actually happen

butterknife's Avatar

butterknife

08 Nov, 2016 02:58 AM

Info from GPGTools

Chromium bug #467296 is the tracker for this. Interestingly, chromium dev team claims this was fixed April 2016 but in august a user reports it is persisting for them.

2016-12-12 Update: Chromium bug #672549 is the newly created tracker for the remaining problem.




Im running El Cap and installed GPG keychain v.1.3.2(1245).

I am finding that there is something very wrong with either the install or my system. I have gone through the tuts and help docs as well as a multitude of other discussions. here is what happens:

in chrome, select a pgp message block in full and right click/services/decrypt selection to new window (or any of the other options for that matter)
result: nothing happens.

i have been able to get it to work after a restart but it will eventually stop working.

i opened Console and attempted that just now and here is the error I get...

11/7/16 6:52:09.637 PM Google Chrome[576]: Object could not or did not write the selection to the pasteboard in preparation for a service request

any ideas of whats going on?

thanks!

  1. 1 Posted by butterknife on 08 Nov, 2016 03:03 AM

    butterknife's Avatar

    id like to add that i am getting a flood of pasteboard errors in Console when running chrome. apparently there is an extension that may be causing this - i am not sure which yet. I understand that an extension called pushbullet is a culprit, but i dont know what that is and dont have it installed.

    i am running chrome Version 54.0.2840.71 (64-bit)
    with the following extensions:
    adblock
    1password
    mightytext
    GDrive
    Netflix Go
    The Great Suspender
    Windscribe
    Dropbox for Gmail

  2. 2 Posted by butterknife on 08 Nov, 2016 03:13 AM

    butterknife's Avatar

    found this thread that was closed without a resolution... same errors and issues on my end...
    https://gpgtools.tenderapp.com/discussions/problems/36367-nothing-h...

  3. Support Staff 3 Posted by Steve on 08 Nov, 2016 10:55 AM

    Steve's Avatar

    Hey butterknife,

    welcome to the GPGTools support platform. Sorry you are having problems using GPG Suite.

    Chromium bug Issue 467296 is the tracker for this. Interestingly, chromium dev team claims this was fixed April 2016 but in august a user reports it is persisting for them.

    I am not sure, but there may be a regression in chromium that made this bug reutrn. Could you update their tracker with your findings and experience.

    As a workaround, can you copy / paste the cyphertext to TextEdit and decrypt from there?

    All the best,
    steve

  4. 4 Posted by butterknife on 09 Nov, 2016 04:22 AM

    butterknife's Avatar

    Thanks Steve.

    I disabled all extensions in chrome and restarted my machine. I was then able to make full use of the tools until extensions were re-enabled and its back to the same issue.

    what is odd to me is that, no, i cannot just copy to textedit. once the issue takes hold, its systemwide, textedit is just as useless.

    ill see about updating the chromium tracker.

  5. Support Staff 5 Posted by Steve on 14 Nov, 2016 06:36 PM

    Steve's Avatar

    Thanks for the update.

    Are you able to isolate a single extension or does that not matter at all any activating any extension will lead to this problem?

    From what you describe it sounds pretty severe. Google has this at priority 2. Not sure if there is a chance to get the priority raised.

    Please keep us posted if any new findings surface.

  6. 6 Posted by butterknife on 15 Nov, 2016 05:03 AM

    butterknife's Avatar

    Steve - thanks for the reply.

    I havent had time to whittle down the extensions. I have, however, added a new extension that allows me to temporarily enable and disable all extensions in chrome. I just restarted a minute ago to be able to use the gpgtools as it just stopped working again.

    Its frustrating in that I can't quite figure out what is happening to cause it to stop working.

    here is what ive found so far after a few days of using gpgtools on and off.

    • a restart guarantees usage of the tools (i am mostly only encrypting/decrypting in textedit currently)
    • attempting to decrypt pgp messages directly from chrome will nearly always fail, whether or not I get one successful attempt or not.
    • I suspect that if i am copy/pasting to and from chrome (which I do a lot with 1password login credentials) that the pasteboard issue will rear its ugly head - assuming that the pasteboard failure it is the culprit here.
    • so far it has been happening after about every 5-10 attempts to decrypt messages. the passphrase dialog box simply does not show up and i get some feedback to the console regarding pasteboard failures.

    i am going to leave the extension in chrome unenabled to see if i can still get a failure.

  7. Support Staff 7 Posted by Steve on 15 Nov, 2016 09:46 AM

    Steve's Avatar

    As mentioned already, this sounds pretty horrible. The next best step is to figure if a single plugin is at fault or if using any plugin at all triggers this chromium issue. Once that is clarified, it is easier to determine where a fix needs to happen.

  8. 8 Posted by Hoot Fluegelhor... on 18 Nov, 2016 12:21 PM

    Hoot Fluegelhorn's Avatar

    Hi Butterknife,
    As a fellow user.. just thinking out loud.. Are you using a clipboard app?

    If so, what happens if you quit that app, or if you clear its cache before you go into a gpg activity?

    Take care,
    Leo

  9. 9 Posted by mjlanders on 23 Nov, 2016 08:32 PM

    mjlanders's Avatar

    Hey there, This is the exact same issue that i'm having. Its very frustrating. I only use Chrome for half of what i do. Even when I quite chrome it doesn't resolve the issue.
    I'm not sure what to do about it.

    If anyone out there has found a fix to this please let me know.

  10. Support Staff 10 Posted by Steve on 01 Dec, 2016 04:02 PM

    Steve's Avatar

    Dear all,

    there was an update a few hours ago on the chromium tracker for bug #467296. Erik from the chromium team wrote:

    If you're seeing this problem, try resetting your pasteboard service by typing the terminal command:

    """ killall pboard """

    And then restart Chrome. If you [shortly] thereafter start seeing this error again, then it's probably because Chrome is leaking pasteboards [again]. I'll need to follow up to determine the source.

    If the problem doesn't shortly reappear, it's probably because some other application is leaking pasteboards.

    So anybody with time on their hands, I am sure the chromium team as well as our team would appreciate any test feedback regarding that latest suggestion.

    The chromium bug is linked at the top of this discussion here.

    Kind regards,
    steve

  11. 11 Posted by butterknife on 02 Dec, 2016 07:13 AM

    butterknife's Avatar

    Thanks Steve. I'll definitely try it out and let you all know. Btw, Ive been posting as giogringo@gmail on the chromium tracker in case there's any confusion

  12. 12 Posted by butterknife on 02 Dec, 2016 08:18 PM

    butterknife's Avatar

    pasteboard failed today and i attempted the "killall pboard" command, then restarting chrome.

    unsuccessful.

    i should note that i have been doing all my decryption/encryption solely through textedit.

    when chrome has not be launched, or not been used to do copy/paste commands, it seems to run without a hitch. as i use chrome and copy/paste, i invariably see the failure

    i will copy this to the chromium tracker as well

  13. 13 Posted by Hoot Fluegelhor... on 03 Dec, 2016 12:29 PM

    Hoot Fluegelhorn's Avatar

    Wow.. some solid troubleshooting there Butterknife!
    Thanks for sharing this. Kudo's

    Leo

  14. 14 Posted by butterknife on 09 Dec, 2016 05:20 AM

    butterknife's Avatar

    I've been over at the chromium ticket trying to arrive at a solution. we are whittling away at it as you may have seen in that ticket you posted

    you may have also seen that i clarified the issue a little further since I didnt really understand the core issue of that chromium pasteboard bug and what issues it caused for other users (e.g., the reason for that tickets existence)

    so i was just sort of glomming in my issues and expecting that everything was abreast of the situation.

    thanks Hoot.

    update:

    so now the fine folks over at chromium have made a new, more specific ticket to track this issue as it pertains to the gpgtools.

    im not sure how to CC you (Steve) on it yet, but here is the url if you want to bookmark it and follow along. meanwhile ill try to get you added to the cc list.

    https://bugs.chromium.org/p/chromium/issues/detail?id=672549#c2

  15. 15 Posted by butterknife on 09 Dec, 2016 05:30 AM

    butterknife's Avatar

    actually - steve... i dont know your email, so unless you want to divulge, its probably best if you ask Erik to add you to that ticket.

  16. Support Staff 16 Posted by Steve on 12 Dec, 2016 03:30 PM

    Steve's Avatar

    Subscribed to the new bug.

    What I am curious about is the fact, that I am running chromium and not running into the bug.

    Can you share a list of the chrome extensions you are using(here and in the chrome bug)?

  17. Steve closed this discussion on 20 Apr, 2017 03:06 PM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac