GPG Keychain: Extended subkey shows as expired & encryption impossible

Anuška's Avatar


02 Sep, 2016 09:43 AM


My key expired, so I extended it. I also extended the subkey, however, a person who is trying to encrypt to my key cannot encrypt. It seems that my subkey - regardless of the fact that it was extended in GPG Suite - shows as expired (for example in Mailvelope), so perhaps this is the reason why this person cannot encrypt to my key (ID: C53D7B5D).

Please, advise how to solve this without having to generate a new key.

Thanks so much!!


  1. Support Staff 1 Posted by Steve on 02 Sep, 2016 01:04 PM

    Steve's Avatar

    Hey Anuška,

    welcome to the GPGTools community support platform. Sorry you are having problems using GPG Suite.

    You updated your subkey, which was the correct thing to do. You need to understand that this will not update public keys of yours stored in other locations.

    If you use the key servers, upload your updated key. Anybody looking will find the updated version. And friends with an expired version of your public key can update the key using the key servers. If you use your public and or secret key in mailvelope the same applies: you'd need to add your updated version of your key.

    Does that make any sense?

    All the best,

  2. 2 Posted by anuska.delic on 02 Sep, 2016 01:37 PM

    anuska.delic's Avatar

    Hi, Steve!

    Yes, I uploaded the updated key to the server, and I uploaded it to Mailvelope. It is still not working. The person cannot encrypt to my key.

    This is why I checked the key out in Mailvelope to see if there's something there that I can't see in GPG. And this is what was different - the subkey still appeared expired (this was after I updated the key in Mailvelope), so I thought this was the reason that the person cannot encrypt.

    What else could it be?! :(


    Thank you.


  3. Support Staff 3 Posted by Steve on 02 Sep, 2016 01:40 PM

    Steve's Avatar

    Let's ignore the mailvelope problem for now. It should not be related to the question wether your contact is able to encrypt using your public key or not.

    I suggest you verify that your contact is using the correct public key and also has updated your key from the key servers. This is also a good chance you verify and sign each others keys: This KB-article explains how to verify and sign a key.

    Let me know if that worked.

  4. 4 Posted by anuska.delic on 02 Sep, 2016 02:02 PM

    anuska.delic's Avatar

    Thank you, Steve. I'll verify that the person is using the updated key and suggest we try signing each other's keys. Will post back if it worked.


  5. Support Staff 5 Posted by Steve on 21 Sep, 2016 01:05 PM

    Steve's Avatar

    Hey Anuska, just a ping on this. Do you need further assistance or can this discussion be closed?

  6. 6 Posted by anuska.delic on 21 Sep, 2016 01:42 PM

    anuska.delic's Avatar

    Sorry I didn't respond. Nothing worked eventually, so we found a different way. Close it up. And thank you.

  7. Support Staff 7 Posted by Steve on 21 Sep, 2016 02:05 PM

    Steve's Avatar

    I'm closing this discussion. Should you need further assistance or have questions you can re-open this discussion here or open a new one any time.

    Best, steve

  8. Steve closed this discussion on 21 Sep, 2016 02:05 PM.

  9. Steve closed this discussion on 27 Aug, 2018 12:36 PM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts


? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac