GPGServices: does not show services any more, when I right click a file

Sune Joergensen's Avatar

Sune Joergensen

30 Aug, 2016 02:59 PM

I used to be able to encrypt/decrypt a file, when I right clicked it. In services, it would show “OpenGpG encrypt” for instance. It does not show any more. And I have tried to tick these services n´both on and of. They show as ticked, but do not not show up when I choose Services, when right clicking a file.

Expected
I expected to see the usual service choices displayed, but they are not there any more

Mac OS X        10.11.6             (15G31)
Libmacgpg       0.7         769 
GPGMail         2.6.1       1151
GPG Keychain    1.3.1       1223
GPGServices     1.11        907 
MacGPG2         2.0.30      875 
GPGPreferences  2.0         887 
Pinentry        0.9.7       2
  1. Support Staff 1 Posted by Steve on 02 Sep, 2016 01:32 PM

    Steve's Avatar

    Hey Sune,

    welcome to the GPGTools community support platform. Sorry you are having problems using GPG Suite.

    So you are decrypting the file in Finder. Do the GPGServices options show if you navigate via the menubar? Finder > Services > OpenPGP: ....

    Do they show if you open TextEdit write "test" and then try to encrypt + decrypt via right-click?

    Do you recall when exactely the entires went missing? Have you recently installed any software?

    All the best,
    steve

  2. Support Staff 2 Posted by Steve on 02 Sep, 2016 01:32 PM

    Steve's Avatar

    Oh and could it be you are using Commander One?

  3. 3 Posted by Sune Joergensen on 02 Sep, 2016 01:41 PM

    Sune Joergensen's Avatar

    Sune Joergensen
    Friends Forever (Int) Ltd
    [email blocked]
    +49 (0)176 65 33 33 95
    +45 24 40 19 63

    Dear Steve,

    Thanks for this

    Replies to your questions:
    1. Yes, the options do show, when I navigate Finder>services>Services preferences

    2. YEs, they do show, when I wrote “test” in text edit and I did both encrypt and decrypt via right click.

    3. I think it was when I updated OPENgpg some time ago.
    I had not installed any new software at that time.

    Best regards

    Sune

  4. 4 Posted by Sune Joergensen on 02 Sep, 2016 01:44 PM

    Sune Joergensen's Avatar

    I have installed commander One recently, could that be the reason?

    But I am using Finder when I try to en- and decrypt files.

    Sune Joergensen
    Friends Forever (Int) Ltd
    [email blocked]
    +49 (0)176 65 33 33 95
    +45 24 40 19 63

  5. Support Staff 5 Posted by Steve on 02 Sep, 2016 01:46 PM

    Steve's Avatar

    Thanks a lot for the follow up. We've had a few users report problems with Commander Pro and reproduced the problem here as well.

    So what happens is, Commander Pro seems to completely remove the Services menu in macOS finder.

    I would consider this behavior fairly intrusive since it tampers with core macOS functionality.

    Please contact Eltima support? It would be great to keep us posted about any responses or fixes that may come out of Eltima.

    All the best,
    steve

  6. 6 Posted by Sune Joergensen on 02 Sep, 2016 01:51 PM

    Sune Joergensen's Avatar

    Dear Steve,

    Thank you so much for this.

    I removed Commander One, restarted the computer, and now all is back to normal.

    Thanks again, since I use it all the time.

    I’ll try to report to Eltima support. And keep you posted about it.

    best regards

    Sune Joergensen
    Friends Forever (Int) Ltd
    [email blocked]
    +49 (0)176 65 33 33 95
    +45 24 40 19 63

  7. Support Staff 7 Posted by Steve on 27 Sep, 2016 08:20 AM

    Steve's Avatar

    Commander One 1.6.0 has been released and no longer tampers with the Services menu in macOS.
    We recommend to either leave Commander Pro uninstaller or update Commander One.

  8. Steve closed this discussion on 27 Sep, 2016 08:20 AM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac