GPGServices: gpgservices right click options not showing in finder when Commander One Pro is installed

Kester Mielke's Avatar

Kester Mielke

12 Aug, 2016 10:23 AM

This comment was split from the discussion: GPGServices: gpgservices on a mac

Hi Steve,

same here. It's still not working. I tried to encrypt a file using the finder. But the services are not shown using the finder. It's working fine in TextEdit.


  1. Support Staff 1 Posted by Steve on 12 Aug, 2016 10:25 AM

    Steve's Avatar

    Hey Kester,

    welcome to the GPGTools community support platform. Sorry you are having problems using GPG Suite.

    Whenever you need assistance with GPG Suite, please create a new discussion. While it is common on other forums to join existing discussions with similar or identical problems, for the GPGTools support forum, this is not a good idea. Having many users in one discussion is likely to cause confusion, thus it's best to solve issues on a "per case" basis. That helps to keep the discussion straight forward and provide a fast solution to you and other users.

    I have thus split your comment into a separate discussion.

    Are you using other Services? If so, could you temporarily disable them and see if that brings the OpenPGP services to your right click options in finder. After disabling other services please restart your mac.

    All the best,

  2. 2 Posted by Kester Mielke on 16 Aug, 2016 07:51 AM

    Kester Mielke's Avatar

    Hi Steve,

    good news. ;)

    i found the problem. I have the "Commander One Pro" installed and the service of this tool seems to have a problem because it's deactivating most of the other services. Everything is working as expected when this services is disabled.

    best regards

  3. Support Staff 3 Posted by Steve on 17 Aug, 2016 01:13 PM

    Steve's Avatar

    Hey Kester,

    thanks a lot for the follow up. We've had a few users report problems with Commander Pro. So what happens is, Commander Pro seems to completely remove the Services menu in macOS finder.

    I would consider this behavior fairly intrusive since it tampers with core macOS functionality.

    Did you report this problem to Eltima support? If not, I'd suggest to do so - maybe they are not aware of this problem. It would be great to keep us posted about any responses or fixes that may come out of Eltima.

    All the best,

  4. 4 Posted by Kester Mielke on 18 Aug, 2016 06:22 AM

    Kester Mielke's Avatar

    Hi Steve,

    i reported the problem to the etima support and will post the answer here if i get one.


  5. 5 Posted by Kester Mielke on 18 Aug, 2016 11:27 AM

    Kester Mielke's Avatar

    Here we go...

    The answer...

    Hello Kester,

    Thank you for contacting us.

    We are aware of this issue. It will be fixed in the following update of
    the app.

    Kind regards,

    Jaroslaw Kladko | Eltima Support |

  6. Support Staff 6 Posted by Steve on 18 Aug, 2016 11:28 AM

    Steve's Avatar

    So that's good news. Please ping again should you notice any update of the Commander software.

  7. Support Staff 7 Posted by Steve on 27 Sep, 2016 08:19 AM

    Steve's Avatar

    Commander One 1.6.0 has been released and no longer tampers with the Services menu in macOS.
    We recommend to either leave Commander Pro uninstaller or update Commander One.

  8. Steve closed this discussion on 27 Sep, 2016 08:19 AM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts


? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac