GPGServices: gpgservices on a mac

cassiope's Avatar


04 Jul, 2016 04:52 PM

The services don't show

The services to encrypt and decrypt to show when pressing the right mouse

Mac OS X        10.11.5             (15F34)
Libmacgpg       0.7         769 
GPGMail         2.6         1150
GPG Keychain    1.3         1220
GPGServices     1.11        907 
MacGPG2         2.0.30      875 
GPGPreferences  2.0         887 
Pinentry        0.9.7       2
  1. Support Staff 1 Posted by Steve on 14 Jul, 2016 09:11 AM

    Steve's Avatar

    Hey Rob,

    welcome to the GPGTools community support platform. Sorry you are having problems using GPG Suite.

    1. Following is our 'How do I activate GPGServices?' Knowledge Base article


    Sometimes GPGServices will not show in the contextual menu after installing GPG Suite. Please check, that GPGServices are activated correctly:

    • open System Preferences > Keyboard > Keyboard Shortcuts > Services
    • GPGServices needs to be activated in two locations
      1. The Files and Folders section GPGS_sys_pref_files.jpg
      2. The Text section please activate: GPGS_sys_pref_text.jpg

    With both sections enabled, retry to use GPGServices from the contextual menu. In case the issue persists, also try using the services menu from the menubar, e.g. TextEdit > Services > OpenPGP:


    2. Following is our ' GPGServices installed but not showing up in services menu' Knowledge Base article


    In rare occasions, GPGServices may not show in the contextual menu and the menubar, despite being correctly activated.

    1. Download and install the latest GPG Suite

    Should the issue persist:

    1. Download and install Onyx
    2. launch Onyx
    3. select "Automation" and make sure all three "Maintenance" options are ticked
    4. press "Execute"to start
    5. once the process is done, restart your system


    After the system restart, open TextEdit and see if GPGServices shows in the contextual menu.

    Let me know if this did work and if it didn't, which exact app you are trying to use the GPGServices with.

    All the best,

  2. 2 Posted by cassiope on 15 Jul, 2016 05:36 PM

    cassiope's Avatar


    The issue remains even after the proposed remedy.
    Otherwise I wouldn’t have reported it.



  3. Support Staff 3 Posted by Steve on 15 Jul, 2016 06:02 PM

    Steve's Avatar

    Ok, in that case "Let me know if this did work and if it didn't, which exact app you are trying to use the GPGServices with."

  4. 4 Posted by Kester Mielke on 10 Aug, 2016 08:49 AM

    Kester Mielke's Avatar

    This comment was split into a new discussion: GPGServices: gpgservices right click options not showing in finder when Commander One Pro is installed

    Hi Steve,

    same here. It's still not working. I tried to encrypt a file using the finder. But the services are not shown using the finder. It's working fine in TextEdit.


  5. Support Staff 5 Posted by Steve on 17 Aug, 2016 02:26 PM

    Steve's Avatar

    Also, do you happen to be using Commander One?

  6. 6 Posted by cassiope on 17 Aug, 2016 04:02 PM

    cassiope's Avatar

    Yes, Commander One is in use.

  7. Support Staff 7 Posted by Steve on 17 Aug, 2016 04:04 PM

    Steve's Avatar

    Thanks a lot for the follow up. We've had a few users report problems with Commander Pro. So what happens is, Commander Pro seems to completely remove the Services menu in macOS finder.

    I would consider this behavior fairly intrusive since it tampers with core macOS functionality.

    Did you report this problem to Eltima support? If not, I'd suggest to do so - maybe they are not aware of this problem. It would be great to keep us posted about any responses or fixes that may come out of Eltima.

    All the best,

  8. Support Staff 8 Posted by Steve on 27 Sep, 2016 08:19 AM

    Steve's Avatar

    Commander One 1.6.0 has been released and no longer tampers with the Services menu in macOS.
    We recommend to either leave Commander Pro uninstaller or update Commander One.

  9. Steve closed this discussion on 27 Sep, 2016 08:19 AM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts


? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac