cant import public key

Richard's Avatar


22 Jan, 2012 01:00 AM

I am trying to import a public key from a friend so we can use pgp encrypted email.

I have a text file of his public key - attached

I have tried to import this test file into GPG Keychain Access in three ways:

  • using the 'import' button in the GPG Keychain Access window;
  • copy-pasting the text into the GPG Keychain Access window; and
  • control-clicking the textfile and selecting Services - OpenPGP: Import

With every attempt I get an error message "Import Failed! Code = 0" see screenshot attached

How can I import this key?


  1. Support Staff 1 Posted by Luke Le on 22 Jan, 2012 09:10 AM

    Luke Le's Avatar

    Hi Richard,

    I've looked at your attached file and there are two errors to find in the format
    of the file.

    On the first line, the first "-" and then space have to be removed, all further dashes are correct.
    The same problem is to be found on the last line.
    Again, remove the first dash and space and leave the rest as it is.
    I've attached a modified correct file for you to see and compare.
    After that you should be able to import the key without problems.

    Let me know if that worked for you!

  2. 2 Posted by Richard on 23 Jan, 2012 08:50 AM

    Richard's Avatar

    Thanks Luke - all fixed

  3. Support Staff 3 Posted by Steve on 26 Jan, 2012 10:57 PM

    Steve's Avatar

    Thanks for your feedback. If you encounter further problems feel free to open a new discussion.

    All the best, steve

  4. Steve closed this discussion on 26 Jan, 2012 10:57 PM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts


? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac