gpgservices on 10.8

Ben Gidley's Avatar

Ben Gidley

27 Nov, 2012 02:46 PM

Hi,

I have installed GPGServices on 10.8.2 and the right click menu for text fields isn't working in many programmes. I have followed the notes in http://support.gpgtools.org/kb/how-to/how-to-activate-gpgservices and the services say they are enabled, however they won't appear in Outlook for Mac or TextEdit. Some of the tools (the Encrypt in new window) do appear in text areas (such as on a web page) but I never get the standard services.

Any ideas how I can get them to activate?

  1. Support Staff 1 Posted by Luke Le on 27 Nov, 2012 03:33 PM

    Luke Le's Avatar

    Hi Ben,

    when you active GPGServices in System Preferences, please make sure, that you activate all services under Files & Text. You'll have to scroll down pretty far to come to the text related Services, so that's a pretty common mistake.

    We'll have to find a way to makes this even easier to setup, but it will still take some time.

    Hope that helps.

  2. 2 Posted by Ben Gidley on 27 Nov, 2012 05:02 PM

    Ben Gidley's Avatar

    Hi,

    I tried that - I had already selected them however repeatedly I select them, exit settings, go back in and they appear unselected! Any idea what could cause that?

  3. Support Staff 3 Posted by Luke Le on 27 Nov, 2012 05:39 PM

    Luke Le's Avatar

    Ha, now that's a new one.
    Is this only related to GPGServices entries or does that Happen for other entries as well?
    Repairing permissions might help since it sounds like it might be connected to a permission problem.

  4. 4 Posted by Ben Gidley on 28 Nov, 2012 07:36 AM

    Ben Gidley's Avatar

    Actually now I test it's all text services. I tried repair permissions in disk utility and that hasn't helped.

    Do you know where is these settings are saved? - I can't find them on disk to check the permissions.

  5. Support Staff 5 Posted by Luke Le on 28 Nov, 2012 03:27 PM

    Luke Le's Avatar

    Hi Ben,

    one thing. If you haven't already, could you install the GPGServices version from https://nightly.gpgtools.org ?
    It's the most stable version to date and it should fix your problem.

  6. 6 Posted by Ben Gidley on 28 Nov, 2012 03:51 PM

    Ben Gidley's Avatar

    I have tried that - I suspect as you suggested it is a permissions issues but I can't find any documentation on where OSX stores those settings!

  7. Support Staff 7 Posted by Luke Le on 28 Nov, 2012 03:56 PM

    Luke Le's Avatar

    It basically all ends up in ~/Library/Preferences, but I'm not sure where keyboard related preferences are stored.
    You could run OnyX. We've proposed that to some users and it helped solve their issues.

  8. 8 Posted by Ben Gidley on 28 Nov, 2012 05:19 PM

    Ben Gidley's Avatar

    -----BEGIN PGP SIGNED MESSAGE----- Hash: SHA1

    OnyX permission clean up worked! I'm not sure what it changed but the end result is I can now enable the service! Just to prove it..
    -----BEGIN PGP SIGNATURE-----

    iQEcBAEBAgAGBQJQtkerAAoJEMZcluWEIkKGKrEIAJ1jSHUN0iga48ix0h4jU+Gw
    xQuhVefzhvs+UoGw2htrH7TvUPCyBRTL70SO7/k6/Myx6CINNEJibYBB7oMsTQx0
    4X461iG4xTXkiNxpbyKRozj6kc55SpmBE3n/q6YlGTPN6oUizwrp//DiPIgxu6+2
    pLYQCPuexpzT/XzNf8OxOz2RTvT9Sc2N0RMYfohjLhUoFZl+961ZFiQO7zRzbP3c
    5olUUZ0EvdwuVM4/ip9vEHI1GPyMn+UIE+w6iI7Qe+R02s6kS3HlslHpOI17hSf6
    9ci+JzfJ6iIIxuJ2EyLFpy8nEvshpMK+uwaomKPr6FT8eBaEMwS/6DLyCMgSK54=
    =yDHK -----END PGP SIGNATURE-----

  9. Support Staff 9 Posted by Luke Le on 07 Dec, 2012 02:54 PM

    Luke Le's Avatar

    Sorry, your last message for some strange reason ended up as spam.
    Fantastic to see it's working now :)!

    Closing this discussion. Feel free to open a new one anytime should you have questions or run into a problem.

  10. Luke Le closed this discussion on 07 Dec, 2012 02:54 PM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac