Disabling signing messages in GPGMail

jashan's Avatar

jashan

26 Nov, 2012 04:23 PM

I believe I remember that there was a setting for this in earlier versions of GPGMail - but in my current version (2.0.a31, Build 111645), I don't find this in the settings.

When I create a new message from a mail-address where have a private key, GPGMail automatically ticks "sign" - even when sending messages to people of whom I don't have the public key. When I don't have a public key, that usually means the receiver does not have PGP, so the signature is just gibberish to them, which I'd like to avoid.

I believe in previous versions, GPGMail remembered the setting (i.e. when I unchecked, it kept it unchecked) but in the current version, it keeps on "checking" sign; so I'd rather completely disable it. I wouldn't even mind disabling this for encrypted messages.

Is there any way this can be achieved?

  1. 1 Posted by Denny Deaton on 27 Nov, 2012 04:21 PM

    Denny Deaton's Avatar

    +1 This is causing issues for me as well.

  2. Support Staff 2 Posted by Luke Le on 27 Nov, 2012 04:23 PM

    Luke Le's Avatar

    Hi Jashan, Denny,

    this is a very tedious bug which has still to be sorted out, but it's our top priority and most likely the most server bug at the moment.

    A new version which has this problem fixed should be out in a few weeks.
    Sorry for the inconvenience.

  3. 3 Posted by Denny Deaton on 27 Nov, 2012 04:25 PM

    Denny Deaton's Avatar

    Hi Luke,

    Thanks for the immediately attention and update! Could you keep us posted on when the bug is fixed?

    Regards,

    Denny Deaton
    Gotham Digital Science
    125 Maiden Lane Third Floor - New York, NY 10038
    [Office] 212.514.8318 ext. 9 [Mobile] 704.604.1970 [Fax] 646.349.3911
    [Blog] http://www.gdssecurity.com/l/b/

    This message is private and confidential. If you have received this message in error, please notify us and remove it from your system.

  4. 4 Posted by jashan on 27 Nov, 2012 06:26 PM

    jashan's Avatar

    Thank you for looking into this. I noticed it's sporadic, so good luck on fixing it! Personally, I'd be happy with a way to just fully disable signing. But that's obviously just a workaround and probably other people wouldn't be too happy with that.

  5. Support Staff 5 Posted by Luke Le on 27 Nov, 2012 07:33 PM

    Luke Le's Avatar

    The next version of GPGMail which will have this bug fixed will try to learn from previously sent messages. So after a short period of learning only very few false positives should be seen.

    Basically it checks for each sender and recipient was method if any was used in the past. If no information was found, it will check if more signed or unsigned, encrypted or plain messages were sent and decide based on that information.
    There's more to it, but simply a little detail to give you an overview on how it will work.

  6. Steve closed this discussion on 20 Jan, 2013 07:36 PM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac