Drafts appear inline with GPG bundle, but not without on IMAP mail account #830

eric's Avatar


16 Feb, 2015 11:26 PM

When I am composing a message, it appears inline with threaded conversation view enabled. I would consider this a issue minor, and in fact I prefer it to appear inline, but it is different from the way Mail.app works without the bundle.

Reproducing the issue:

  1. With GPGMail.mailbundle installed as usual, send yourself an encrypted, signed message (in my example, I used a different email that I also owned to be sure the issue was not limited to emailing yourself at the same address)
  2. Reply to your own message, and start typing some text
    3, Save the reply as a draft, or press command+0 to switch to the main mail window and wait about 30 seconds
  3. As shown in Screen Shot 1, you will see your original email, but you also see your draft reply from the Drafts email box along with whatever you have typed so far

To show how this is different from Mail.app without the bundle:

  1. Quit Mail.app
  2. In the terminal, sudo mv /Library/Mail/Bundles/GPGMail.mailbundle /Library/Mail/Bundles\ \(disabled\)/
    3, Launch Mail.app
  3. Once again reply to your thread and start typing
  4. Save the reply as a draft, or command+0 to switch to the main mail window and wait about 30 seconds
  5. As seen in screen shot 2, you will not see your draft inline

Now to get yourself back into working order and illustrate the difference again:

  1. Quit Mail.app
  2. In the terminal, sudo mv /Library/Mail/Bundles\ \(disabled\)/GPGMail.mailbundle /Library/Mail/Bundles/
  3. Launch Mail.app
  4. Select your thread from the message list
  5. As seen in Screen Shot 3, you will notice your previous draft is inline, even before you have edited the message or replied

After a while, I've come to actually prefer the current behavior with GPGMail, because I can see my drafts inline if I decide to come back to them later. But as I said, I only point it out because it is different from the default behavior of Mail.app (and because Steve suggested I open another discussion :-) ).

  1. Support Staff 1 Posted by Steve on 01 Mar, 2015 06:14 PM

    Steve's Avatar

    Hi Eric,

    thanks for the clear description. I tried to reproduce this problem, but couldn't.

    I sent an encrypted and signed mail to myself. Then replied to that. Stored the reply as draft, but never saw the draft reply in the threaded view (which I have activated). see screenshot.

    Now I wonder either how our actions might differ or if they are identical, in which aspect our mac systems differ.


  2. 2 Posted by eric on 01 Mar, 2015 09:15 PM

    eric's Avatar

    I was able to verify that if I check "Encrypt Drafts" in the GPGMail preferences tab in the Mail.app preferences, then the behavior changes, and the draft does not appear inline. So it may have something to do with encrypted vs unencrypted drafts. And in case it is also relevant, I do not save drafts on the server.

  3. 3 Posted by Piero Malcovati on 04 Mar, 2015 12:29 PM

    Piero Malcovati's Avatar

    I confirm that with Encrypt Drafts active drafts are not shown inline in conversations, whereas with Encrypt Drafts inactive they are shown inline. Moreover, when drafts are shown inline (Encrypt Drafts inactive) they are NOT deleted when the message is sent!

  4. Support Staff 4 Posted by Luke Le on 01 Apr, 2015 05:04 PM

    Luke Le's Avatar

    Hi Piero,

    would you mind also posting your steps to reproduce this?
    Best with screenshots or what would be wonderful is a screencast (if it's not too much work)

    What baffles me is that the behavior is worse (message not deleted) if encrypt drafts is inactive, since in that case GPGMail doesn't interfere with mail. Only it the case that encrypt drafts is active, GPGMail does its own thing.

  5. Support Staff 5 Posted by Steve on 01 Apr, 2015 05:52 PM

    Steve's Avatar

    I have experimented with drafts and am noticing showing up in threaded view with GPGMail installed as well. The situation is a little worse on 10.9 but also exists on 10.10.

    We have a ticket for this problem. I connected this discussion with the existing ticket. That means, should this discussion get closed, it will be re-opened as soon as the ticket is closed. That way you'll receive a notification. Feel free to open a new discussions should you run into further problems or need assistance.

  6. Support Staff 6 Posted by Steve on 01 Apr, 2015 05:53 PM

    Steve's Avatar

    Eric and Piero, could you briefly state if you are using IMAP or POP accounts when this issue is happening?

  7. 7 Posted by eric on 01 Apr, 2015 06:15 PM

    eric's Avatar

    IMAP for me.

  8. 8 Posted by Piero Malcovati on 01 Apr, 2015 07:05 PM

    Piero Malcovati's Avatar

    IMAP also for me with draft mailbox only local (not synchronized).

  9. Support Staff 9 Posted by Steve on 14 Aug, 2015 12:52 PM

    Steve's Avatar

    Closing for now. We will let you know as soon as we have news regarding this problem.

  10. Steve closed this discussion on 14 Aug, 2015 12:52 PM.

  11. Support Staff 10 Posted by Steve on 07 Mar, 2018 01:07 PM

    Steve's Avatar

    The bug where Mail.app created multiple drafts has been fixed by Apple in macOS 10.13. If you are still affected by this issue, consider updating to macOS 10.13 High Sierra.

  12. Steve closed this discussion on 07 Mar, 2018 01:07 PM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts


? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac