Creating pastable encrypted text?

vk2003's Avatar

vk2003

22 Nov, 2012 11:05 PM

I am new here.
I have read the help files more than once.
It is entirely possible I am being dense - but if someone could put me out of my misery and tell me where I am going wrong, I would be most grateful!.

Running OSX 10.7.4. Installed GPG package, and then the latest nightly builds of keychain access and GPGservices following threads here in the forum.

I have the public key for someone to whom I wish to send a message, but I have to paste the text into a message field to them rather than sending a file or email.

I have imported their public key into keychain. It shows up, and has their email address correctly listed too.

I created a text file (with textedit, saved as plain text) with the desired message within. Saved it, and then from within Finder used the services menu to encrypt the file - I selected the public key of the person for whom the message was destined. I also had to sign the encryption with my own key (or the process failed unless I unticked the "add to Recipients" box).

What was created was a file called <filename.txt.gpg>

This I was able to decrypt by just double clicking, but couldn't open it to copy the encrypted message for pasting.

Can anyone advise where I am going wrong please? Thanks in advance

  1. Support Staff 1 Posted by Luke Le on 22 Nov, 2012 11:12 PM

    Luke Le's Avatar

    Hi vk,

    you've almost done everything right, except you've encrypted the file itself instead of only the text.
    So follow these steps:

    1.) Open the original file (unencrypted) in TextEdit
    2.) Select the whole text
    3.) Right-click and select Services-> OpenPGP: Encrypt Selection
    4.) And voilà, you have the encrypted text

    (there's a slight chance it won't be that easy if you find a bug)

    Hope that helps.

  2. 2 Posted by vk2003 on 22 Nov, 2012 11:16 PM

    vk2003's Avatar

    Hi Luke

    Thanks for your speedy response. I did try doing the above (before I posted here too!)

    BUT

    From within Textedit, there is are services in the contextual menu, and selecting services from the menubar menu presents no encryption/GPG options at all - hence I can't do it.

    Any suggestions? (GPG services are enabled as in the faqs which is how I can access them within finder!)

  3. Support Staff 3 Posted by Luke Le on 22 Nov, 2012 11:20 PM

    Luke Le's Avatar

    Ah ok, now that is not good.
    So nightly version is already installed, we've got that covered.

    Could you double check in preferences that the items for Text are also enabled?
    Files and Text are treated differently, which is a pain and can lead to confusion.

    See this screenshot: http://cl.ly/image/0v063l3S0p2v

  4. 4 Posted by vk2003 on 22 Nov, 2012 11:22 PM

    vk2003's Avatar

    OK... further investigation

    I admit to being a dunce....

    Schoolboy error - within services, PGP options were enabled for files and folders. But if you SCROLL DOWN a bit further there is a section for text....

    Can you advise what the Add to Recipients section is for please?

    p.s. our posts crossed over!

  5. Support Staff 5 Posted by Luke Le on 22 Nov, 2012 11:30 PM

    Luke Le's Avatar

    Ah hehe, nah, we've definitely have to find an easier way to set this up. And we will! :)

    With Add to Recipient you define which users should be able to decrypt this text/file. Unless you choose to only encrypt using password (I seriously hate this UI...), in that case you don't have to use add to recipient, but the protection is way easier to break.

    I hope this makes things a bit clearer.

  6. 6 Posted by vk2003 on 22 Nov, 2012 11:36 PM

    vk2003's Avatar

    Cool. Luke, thank you so much for your help

    vk

  7. vk2003 closed this discussion on 22 Nov, 2012 11:37 PM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac