goetz's Avatar


08 Jan, 2012 01:37 PM


I installed the newest version of GPGTools (2011-12-24) with the exception of MacGPG2 (I'm still using version 1.4.11 for special reasons).

Then I started Mail.app, selected an encoded message and was asked for my secret. Unfortunately, I mistyped it and since then I'm unable to get this window show up again. All GPG encoded messages are shown with a yellow label "MESSAGE_BANNER_PGP_DECRYPT_SECKEY_ERROR_TITLE" in Mail.app.

What I already did/checked:
• no passphrase/secret is store in the (Mac) Key Chain

• deleted all preferences

• reinstalled GPGTools

nothing helped. Any ideas are very welcome ...


  1. Support Staff 1 Posted by Luke Le on 08 Jan, 2012 02:03 PM

    Luke Le's Avatar


    the message you're seeing is unfortunately not yet translated but will be in the next version.
    What it means is though that GPG couldn't find the secret key to decrypt your message.
    Could you please open GPG Keychain Access, click on the "only show secret keys" in the right bottom corner and verify that you see the address the message was encrypted to listed there.

    If you've reinstalled your machine recently you might have forgotten to copy your secret key over.

    Hope that helps

  2. 2 Posted by goetz on 08 Jan, 2012 04:12 PM

    goetz's Avatar

    GPG Keychain Access lists my secret key fine. And I can decrypt text using the gpg CLI, it works well.

  3. 3 Posted by Parker on 11 Jan, 2012 08:31 PM

    Parker's Avatar

    Sorry for the "me too" but I see the exact same problem on a fresh install of GPGMail-2.0a21 on top of a fresh install of Lion 10.7.2 and Mail 5.1.

    I also notice that I have no GPG related items on any of Mail's menus. I do see a GPGTools tab in Mail/Preferences. This does not appear to be fully installed and functional.

    When starting Mail for the first time after GPGMail install, I was prompted for pinentry but canceled. I haven't seen the pinentry box since. Rebooted, reinstalled GPGMail, etc.

  4. Support Staff 4 Posted by Luke Le on 11 Jan, 2012 08:35 PM

    Luke Le's Avatar

    The fastest method to debug this problem, which is indeed a very weird one, would be to use screen sharing with one of you two.
    I'd propose doing that using TeamViewer which is very easy to use.
    Of course this is a very sensitive operation, but it would be very helpful if one of you would be willing to try that.

  5. 5 Posted by Parker on 11 Jan, 2012 08:46 PM

    Parker's Avatar

    I can create a clean mailbox and do a screen sharing session with you. Perhaps you could send an encrypted message to it. Drop me an email to arrange it.

  6. 6 Posted by Parker on 11 Jan, 2012 08:57 PM

    Parker's Avatar

    By the way, I tried swapping GPGMail.mailbundle with the -a23 version, but nothing changed.

  7. Support Staff 7 Posted by Luke Le on 12 Jan, 2012 12:19 AM

    Luke Le's Avatar

    @GH: The screen sharing session with Parker worked pretty well, so if you would be willing to do that as well, I think we'll find the solution quickly.

  8. Support Staff 8 Posted by Steve on 28 Jan, 2012 10:54 PM

    Steve's Avatar

    No further user feedback. Closing.

    @GH is you need any further help or assistance please re-open this discussion and we'll be happy to help out.

    All the best, steve

  9. Steve closed this discussion on 28 Jan, 2012 10:54 PM.

  10. goetz re-opened this discussion on 22 Jun, 2012 08:02 PM

  11. 9 Posted by goetz on 22 Jun, 2012 08:04 PM

    goetz's Avatar

    Still having the old problem - new machine, new GPGTools, newest OS X. Can decrypt with CLI-gpg.

    Any hint is appreciated.

  12. Support Staff 10 Posted by Steve on 26 Jun, 2012 09:20 AM

    Steve's Avatar

    Hey Goetz,

    there you are again. We missed you. Could you elaborate on which version of what you are using on your new machine? I assume 10.7.4 and GPGTools Version 2012.03.18 from here https://www.gpgtools.org/installer/index.html?

    Could you please visit http://nightly.gpgtools.org/ and download the latest GPGTools_Installer-trunk.dmg file.

    Run that on your system and see if the problem persists.

    All the best,

    Please consider a donation. We do all this in our spare time.

  13. 11 Posted by nick.hyde on 10 Jul, 2012 09:28 AM

    nick.hyde's Avatar

    I seem to be having the same problem as the previous emails. I downloaded and installed GPGtools version 2012.03.18 on July 8th. Install appeared to go OK and key pair generated successfully. But integration with mail did not work - no PGP options on the 'Mail' 'Message' menu. Tried following instructions in your FAQ "How do I activate GPGServices?" by installing latest "GPGTools installer trunk.dmg" and made sure system preferences were correct. Mail still not working: an encrypted message had error message "secret key to decrypt the message is missing".

    How can I get the system to install correctly so that I can use encrypted email?


  14. 12 Posted by nick.hyde on 10 Jul, 2012 09:45 AM

    nick.hyde's Avatar

    I should also have added to message above that I am running Mac OS X 10.7.4 and before I ran latest "GPGTools installer trunk.dmg" the error message I got was MESSAGE_BANNER_PGP_DECRYPT_GENERAL_ERROR_TITLE, the error message changed to "secret key to decrypt the message is missing" after I ran the latest "GPGTools installer trunk.dmg".


  15. Support Staff 13 Posted by Steve on 10 Jul, 2012 10:39 AM

    Steve's Avatar

    Hey Nick, sorry to hear you are having issues with the setup.

    first: the fact that you now see a correct error message tells us, that the installation of the nightly went fine. Good thing!

    Next we need to differentiate: GPGServices is used for file and text encryption. That is not really related to GPGMail (the plugin used by Apples Mail.app).

    From what you write it seems the sec key to the message you are trying to decrypt is missing.

    Please open GPG Keychain Access and see if it contains your sec key. If you want you can provide screenshots. If those contain sensitive data please set this discussion to private (not sure if you can do that, since your not the OP). If you can't please create a new discussion.

    Hope this helps,

  16. Support Staff 14 Posted by Steve on 22 Jul, 2012 06:29 PM

    Steve's Avatar

    Hi all, since we've received no reply in over 10 days I'm closing this discussion.

    @all: Should any of you still have problems, please open a new discussion so we can have a clean start and provide a detailed error description so we can investigate.

    Cheers and all the best :)

  17. Steve closed this discussion on 22 Jul, 2012 06:29 PM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts


? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac