multiple emails with single key - add user id greyed out

miguel's Avatar

miguel

19 Nov, 2012 07:26 PM

Hi, I am using the beta with support for ML, and I noticed that I cannot add multiple UIDs to keys, as the '+' sign is greyed out.
Is it a problem of my configuration or something known to happen?

  1. Support Staff 1 Posted by Luke Le on 20 Nov, 2012 06:10 PM

    Luke Le's Avatar

    Hi Miguel,

    are you talking about GPG Keychain Access?
    UID's can only be added to keys you own. You can't change public keys.

  2. 2 Posted by miguel on 20 Nov, 2012 06:33 PM

    miguel's Avatar

    Hi,
    my problem stands in the fact that my boss has multiple emails and she decrypts them with the same key.
    In other words, I send emails to [email blocked] or [email blocked] and I would like to encrypt them with the same public key, which was originally associated with [email blocked]
    I thought I could do it before. In thunderbird it was easy to say "send emails to [email blocked] using this public key".

  3. Support Staff 3 Posted by Luke Le on 20 Nov, 2012 07:01 PM

    Luke Le's Avatar

    Aaah ok, I understand.

    You can do this with GPGMail as well but you have to use the terminal.
    Follow these steps to set it up:

    1.) Close Mail.app
    2.) Open Terminal.app (in /Applications/Utilities)
    3.) Type the following line replacing the email and fingerprint with the real values:

    defaults write org.gpgtools.gpgmail PublicKeyUserMap -dict-add email fingerprint
    

    4.) Press Enter
    5.) Restart Mail.app

    After these steps it should work as expected.

  4. 4 Posted by michele casepos... on 20 Nov, 2012 07:14 PM

    michele caseposta's Avatar

    Just another question...how do i get the fingerprint of the proper ssh key? In this case is the key associated with [email blocked]
    Thanks,
    Michele

  5. 5 Posted by michele casepos... on 20 Nov, 2012 07:15 PM

    michele caseposta's Avatar

    nevermind, got it in the info from the GPG keychain access
    thanks again,
    Michele

  6. 6 Posted by michele casepos... on 20 Nov, 2012 07:21 PM

    michele caseposta's Avatar

    Ok, I tried; if I copy/paste the fingerprint as it is in the info it does not work. I then remove the spaces in the fingerprint, and it seems that everything goes fine.
    When I perform the command:

    defaults read org.gpgtools.gpgmail PublicKeyUserMap

    I get this as result:

    {
        "[email blocked]" = longalphanumericfingerprintwithnospaces;
    }

    When I try to send an email, however, the encrypt button is still greyed out, even after restarting mail.
    Any idea?
    Thanks,
    Michele

  7. Support Staff 7 Posted by Luke Le on 20 Nov, 2012 07:25 PM

    Luke Le's Avatar

    Hmm... looks alright basically.
    On what OS X version are you?

  8. 8 Posted by michele casepos... on 20 Nov, 2012 07:34 PM

    michele caseposta's Avatar

    10.7.5
    I just updated and "fixed" gpgtools last week.

  9. Support Staff 9 Posted by Luke Le on 20 Nov, 2012 07:40 PM

    Luke Le's Avatar

    Aaah ok, so the command has to be changed to

    defaults write org.gpgtools.common PublicKeyUserMap -dict-add email fingerprint
    

    And you're absolutely right, the spaces in the fingerprint have to be removed. Forgot to mention that.

  10. 10 Posted by michele casepos... on 20 Nov, 2012 07:51 PM

    michele caseposta's Avatar

    That worked, thanks :)
    Just a quick last question: what will happen when I upgrade to Mountain Lion?
    Will the second command work?

  11. Support Staff 11 Posted by Luke Le on 20 Nov, 2012 07:56 PM

    Luke Le's Avatar

    Yes, exactly.
    Once the official version for Mountain Lion is out, both should.

  12. Steve closed this discussion on 02 Dec, 2012 10:20 AM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac