Decrypting messages

jarris01's Avatar

jarris01

28 Oct, 2012 10:41 PM

Hi,

I'm having massive trouble decrypting a message as it keeps saying 'The “OpenPGP: Decrypt” service could not be used because the “GPGServices” application did not respond to a request for services.' I've read all the other peoples messages that had this problem and have updated all my software from the nightly builds and it's still not working? If I save it to textedit and then on my desktop right click and ask to decrypt, it creates a .tmp file (which have no idea how to open?) so is doing something....

Some help here would be really appreciated! Thanks for any help and for providing such a great piece of software!

P.S Am using mac 10.6.8 and everything else bar decryption is working great...

PPS Something that may help anyone with finding a solution: When using terminal to ask for decyption it comes back with this message 'invalid auto-key-locate list'. Am not sure what it means but thought it may be of use as seems this problem happens to quite a few using Snow Leopard. Thanks again

Environment:

  • Software name and version: (e.g. GPGMail 2.0a4 or GPG Keychain Access 1.0b3)
  • OS X version: (e.g. 10.7.2)
  • GPGTools Installer date:

  • Have you already tried running the latest nightly of the GPGTool Installer? YES

  1. Support Staff 1 Posted by Luke Le on 29 Oct, 2012 12:18 PM

    Luke Le's Avatar

    Hi Jarris,

    that does help indeed.
    Please do the following:

    1.) Open Finder
    2.) Press Cmd (Apple key) + Shift + G
    3.) Enter

    ~/.gnupg/
    

    4.) Press open
    5.) Open the gpg.conf file with the editor of your choice
    6.) Look for the line which starts with auto-key-locate and remove "pka" and "cert"
    7.) Save the file and try again

    Hope that helps.

  2. 2 Posted by jarris01 on 29 Oct, 2012 01:55 PM

    jarris01's Avatar

    Hi Luke,

    Thanks for getting back to me. I've tried your instructions and changed the gpg.config file using textmate. I saved the file but it's still not working? The file however was located on my desktop so that may be a problem? Not sure where to put it and how it arrived there...

    Sorry, not the most technical guy but learning quickly! Thanks again for the software and any help you can provide...I've attached a copy of the config file in case that helps. If you need anymore info to help, please ask. Spent so long trying re-installs, terminal etc. but no luck yet. Thanks again!

    p.s opened terminal and wrote command gpg -d and then pasted the encypted message. It then said:

    -----END PGP MESSAGE-----
    You need a passphrase to unlock the secret key for
    user: [email blocked]....
    gpg: encrypted with 2048-bit RSA key.....

    It writes this twice as says encrypted by myself and sender but doesn't ask for password. Maybe that helps so thought it was worth a mention. Thanks again

    On 29 Oct 2012, at 12:18, Luke Le wrote:

    > ~/.gnupg/

  3. 3 Posted by jarris01 on 29 Oct, 2012 04:47 PM

    jarris01's Avatar

    Hi, Finally managed to decrypt using terminal!! Very happy after many frustrating hours. I'll post what I did incase it helps anyone else but can close discussion for now. Thanks for your help and time!(after making changes to .config file above)
    Typed in terminal gpg -d , then pasted encrypted message and hit enter. It will list names of people who have encrypted your account. It will then not ask you for anything until you press ctrl + d on your keyboard. It then just appeared...Hope that helps anyone with the same problem.

  4. Support Staff 4 Posted by Luke Le on 29 Oct, 2012 08:02 PM

    Luke Le's Avatar

    Hi Jarris,

    great you got it working!
    The gpg.conf should indeed not be located on the Desktop but in your users folder under .gnupg (a hidden folder, you best see with Terminal ls -la ~/)

    So basically to move it into that folder run the following command in Terminal:

    mv ~/Desktop/gpg.conf ~/.gnupg/
    

    Does GPGServices now work as well or still not?

  5. 5 Posted by jarris01 on 30 Oct, 2012 12:55 AM

    jarris01's Avatar

    Hi Luke,

    Thanks for the continued help and detailed instructions! I followed them but unfortunately still not working via the services route. Still, I'm so happy to have worked out how to do it via terminal so all in all am happy. If there is a fix then great. If it's too much, then no probs :)

    Will donate by next week to the cause...hope there's some kind of continued support for SL as really dislike using Mountain Lion for few reasons.

    Thanks!

  6. Support Staff 6 Posted by Luke Le on 01 Nov, 2012 09:19 AM

    Luke Le's Avatar

    Unfortunately Services is a fickle beast. But we're already considering a rewrite which should work much better.

    The good thing (for us) about SL is, that it will not receive anymore updates, so our software should continue to work on it. If time allows we'll certainly reconsider, but at the moment, unfortunately we couldn't support bigger updates to SL.

    Closing this discussion. Feel free to open a new one anytime should you have questions or run into problems.

  7. Luke Le closed this discussion on 01 Nov, 2012 09:19 AM.

  8. jarris01 re-opened this discussion on 04 Nov, 2012 08:52 PM

  9. 7 Posted by jarris01 on 04 Nov, 2012 08:52 PM

    jarris01's Avatar

    Thanks alot for all your help! Apologies for late reply - was away.

  10. Steve closed this discussion on 05 Nov, 2012 11:49 PM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac