Error when trying to decrypt file with GPG Keychain Access

Grant Smith's Avatar

Grant Smith

06 Sep, 2012 09:17 PM

This comment was split from the discussion: Cannot import keys

Hi Luke,

I am surprised to hear form you as I did not believe my efforts to post
were successful. Perhaps it is just a bad day but I was getting an error
message when I attempted to reply to the posts also. In response to your
question I have downloaded an encrypted file from a server that I had
previously sent my key to. When I attempt to import/decrypt the file I
receive the following message:
Import failed!
Code = 0

Error text:
gpg: [don't know]: invalid packet (ctb=7e)
gpg: read_block: read error: Invalid packet
gpg: import from `/dev/fd/5' failed: Invalid keyring
gpg: Total number processed: 0

Please forgive me if this is on my end and something simple but I could
not find anything in the available documentation.

Thanks for your help

  1. Support Staff 1 Posted by Luke Le on 06 Sep, 2012 09:21 PM

    Luke Le's Avatar

    Hi Grant,

    you should have gotten a email confirming that your post was successful. (Not entirely sure though)

    Your attempt fails, because GPG Keychain Access can't be used to decrypt files but is only used to manage your keys.

    What you want to do is to use GPGServices to decrypt the file.

    Basically it should be as simple as right-clicking (ctrl+click) on the file, selecting Services -> OpenPGP: Decrypt file.

    If you don't see that option it's possible you first have to active GPGServices.
    In order to that please follow the instructions on http://support.gpgtools.org/kb/faq/how-do-i-activate-gpgservices

    Hope that helps.

  2. 2 Posted by Grant Smith on 06 Sep, 2012 09:32 PM

    Grant Smith's Avatar

    Luke,
    THANK YOU! It is amazing how simple something is when I finally ask
    someone who knows. The program worked perfect. Have a great day.

  3. Support Staff 3 Posted by Luke Le on 06 Sep, 2012 09:33 PM

    Luke Le's Avatar

    Fantastic, very glad we've worked this out so quickly.
    Have a great day too!

  4. Luke Le closed this discussion on 06 Sep, 2012 09:33 PM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac