Public keys appearing on my GPG Keychain

jon's Avatar

jon

14 Mar, 2014 05:07 AM

I started GPG Keychain Access a few minutes ago and saw a bunch of public keys on it that I didn't place there.

I'm surprised that this could happen. i don't know these people and have not solicited any communication with them.

Question 1: Is this a typical behavior?
Question 2: If this is a typical behavior how do I turn it off?

  1. 1 Posted by jon on 15 Mar, 2014 04:49 AM

    jon's Avatar

    Noticed that an attempt to access my GPG Keychain was made every time I opened the Gnupg-users mailing I'm newly receiving. Then noticed that several of the names of people who were inserted into my GPG Keychain are regulars on the same Gnupg-users mailing. I must have accidentally granted access which permitted adding keys to my Keychain. I'll be more careful about that in the future.

    But still, I'm put off that this would happen without first asking. Deleted unsolicited keys and unsubscribed from mailing.

    Closing this conversation.

  2. jon closed this discussion on 15 Mar, 2014 04:49 AM.

  3. Steve re-opened this discussion on 11 Sep, 2017 03:26 PM

  4. Support Staff 2 Posted by Steve on 11 Sep, 2017 03:26 PM

    Steve's Avatar

    Hi Jon,

    sorry, this one slipped through the cracks. Excuse the super-late reply!

    The behavior you described is due to the auto-key retrieve setting. When you receive a signed message, gpg automatically looks for the public key to verify that signature. You can easily change that setting in GPGPreferences / GPG Suite > Settings.

    Best,
    steve

Reply to this discussion

Internal reply

Formatting help / Preview (switch to plain text) No formatting (switch to Markdown)

Attaching KB article:

»

Attached Files

You can attach files up to 10MB

If you don't have an account yet, we need to confirm you're human and not a machine trying to post spam.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac