Unknown folder appeared in Finder after install of latest version

Louis's Avatar


10 Aug, 2012 09:38 AM

The folder can neither be opened nor removed from the Finder. Is this where
the Private Keys are stored? I have uploaded a screenshot of the relevant
part of the Finder - folder cZxxVkkjYhr8f2.

Also, after the creation of the keys I got the message that the uploading of
the key to the server failed!

Any assistance greatly appreciated. Thanks

  1. Support Staff 1 Posted by Luke Le on 12 Aug, 2012 04:13 PM

    Luke Le's Avatar

    Hi Louis,

    there's really no way this could have happened due to a GPGTools installation, so I guess it was mere coincidence.

    You can simply remove it by doing a right-click on it and selecting "Remove from sidebar".

  2. Support Staff 2 Posted by Steve on 12 Aug, 2012 04:16 PM

    Steve's Avatar

    Hey Louis,

    sorry to hear you are having trouble using GPGTools. Let's try some things to pin down where this problem is coming from.

    Could you please visit http://nightly.gpgtools.org/ and download the latest GPGTools_Installer-trunk.dmg file.

    Run that on your system and see if the problem with the key upload persists. There has been an issue in the past with key upload but it should be fixed in the nightly.

    About that folder: I honestly have no clue where that is coming from.

    All the best,

    Please consider a donation. We do all this in our spare time.

  3. 3 Posted by Louis on 14 Aug, 2012 05:22 AM

    Louis's Avatar

    I thank both Luke Le and Steve for responding to the difficulty I was having. Very kind of you to do so. I always wanted to encrypt my emails but the problem is most of the time the people one communicates with do not use it.

    I tried to drag the folder from the Finder but it 'bounced' back. I tried to open it but it would not open. I tried to 'search my Mac' to see where it was located but the result was '0 items'. I noticed I was also unable to upload my keys to the Keyserver.

    Therefore I started to be concerned. I revoked all the keys I had created, backed up the revoked certificates to an outside Hard Drive and deleted the keys. Then I uninstalled GPGTools. But lo and behold the mystery file was still there after the uninstallation!! Therefore I had to assume that GPGTools was not the culprit. And I was more than concerned now!

    I cloned the OS (sorry I forgot to mention this in my initial post. It is OSX 10.6.8) and made a bootable drive on an external hard drive. I erased my hard drive and then re-installed Snow Leopard from the DVD. That was the only way I could get rid of this folder!! I will never know its contents!

    As I will re-installed GPGTools again soon, could please advise if it is better to use the 'nightly build' or the stable
    one. I am still learning how to use this machine properly.

    Also, I have installed the 'Little Snitch' software. I noticed that whenever I opened Apple Mail with GPGTools installed the mail application wanted to connect to GPGTools.org. Could you advise why. Thank you.

    Thanks again for the assistance.

  4. Support Staff 4 Posted by Steve on 14 Aug, 2012 09:00 AM

    Steve's Avatar

    Hey Louis,

    wow, sorry to hear you going through a lot of pain re-installing OS X. That's really annoying.

    The OS X version info is very important. Since, if you are running 10.6 you don't use the latest GPGMail 2.0 alpha version. 2.0 currently is 10.7 only. And GPGMail 1 won't receive any patches. When we find the time, we might backport GPGMail 2 to 10.6 but that is a little down the priority list (GPGMail is not working on 10.8 currently and that comes first).

    As for the nightly, yes, I'd suggest you test the latest nightly. Since it contains the very latest GPG Keychain Access and the GPGServices which received quite a few nice patches lately.

    Also, using LS you should be rather save and I assume the folder in question was more a little finder glitch than a real threat. But depending on your environment you'd rather make sure you have a clean system.

    Does this answer your questions?

  5. Support Staff 5 Posted by Luke Le on 14 Aug, 2012 09:43 AM

    Luke Le's Avatar

    Hi Louis,

    uh boy, you sure went through a lot, sorry for that!
    As for the Little Snitch problem. You're asked because GPGMail checks if a new version is available and would automatically download and update itself.
    So you can allow that request without worrying.

  6. 6 Posted by Louis on 14 Aug, 2012 10:18 AM

    Louis's Avatar

    Hi Steve & Luke

    Thanks for the replies. As I cannot use GPGMail version 2.0 because I have not upgraded to Lion yet, I suppose I can only use only the latest version of GPG Keychain Access and GPG Preferences which means I will have to deselect GPGMail when I install the GPGTools bundle again. Am I right? This will be no problem because one can always encrypt one's message, sign it in Text Edit and then copy it to Apple Mail. Am I right? Thanks.

    My suspicion is the mysterious folder is related to the Keyserver because soon after it appeared in the Finder I was not able to upload any key. One observation please: why is the generated key immediately uploaded to the sever? Would it not be safer to export the public key via email (in the clear) to the other person to encrypt the message he/she is going to send me? He/she can store it in his/her Keychain Access. In my humble opinion the Keyserver introduces the 'problem' of revocation of unused keys, their deletions and the storage of the revocation certificates. Just a thought….

    Thank you Luke for advising why GPGMail connects to GPGMail.org as soon as one opens Apple Mail. It is good to know what is going on in the background sometimes. :) LS helps.

    Next week I will reinstall GPGPreferences and GPGKeychain access again and I will deselect 'upload to Keyserver before I proceed further and see what happens.

    Thanks again.

  7. Support Staff 7 Posted by Luke Le on 14 Aug, 2012 10:27 AM

    Luke Le's Avatar

    Hi Louis,

    no, GPGMail works very well under 10.6 too, it's only that for OS X Lion we've had to write it from scratch and made it much user friendlier, but of course you can still use it on 10.6

    That the upload of the key failed is due to the fact that the keyservers are very unreliable not much else unfortunately.
    You can change the keyserver in GPG Preferences. The MIT server works quite well.

    Basically the key is immediately uploaded to help novice users with sharing their key. We might provide this as an option in the future.

    Let us know if you have any further questions :)

  8. Support Staff 8 Posted by Steve on 24 Aug, 2012 04:51 PM

    Steve's Avatar

    No further user feedback. Closing.

    @Louis: Should your problem persist, feel free to re-open this discussion any time.

    All the best,

    Please consider a donation. We do all this in our spare time.

  9. Steve closed this discussion on 24 Aug, 2012 04:51 PM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts


? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac