Problems importing a public key

Eric Stobbart's Avatar

Eric Stobbart

09 Aug, 2012 07:27 PM

I'm getting code = 0. I saw a few people with the same symptoms but I was
unable to fix it using the solutions that worked for them.

The file was originally .asc extension I've tried all methods with the
extension .asc & .pgp
I've tried the following.

1) Gui -> import button

2) Command line
Eric-4:/ Eric$ gpg --import ~/Desktop/kolla.asc
gpg: /Users/Eric/.gnupg/gpg.conf:233: invalid auto-key-locate list

If I comment out line 233.

Eric-4:/ Eric$ gpg --import ~/Desktop/kolla.asc
gpg: no valid OpenPGP data found.
gpg: Total number processed: 0

3) Option-click->service->Import key from file.

Nothing seems to work. All say error code =0 failure to import.

I've attached the key.



  1. Support Staff 1 Posted by Steve on 12 Aug, 2012 03:55 PM

    Steve's Avatar

    Hey Eric,

    sorry to hear you are having issues importing the key. Could you please visit and download the nightly GPGTools_installer and run that on your system. Just recently we´ve written a few patches for GPG Keychain Access.

    Thanks for attaching the key in question. I was able to import that key via copy and paste when using the latest nightly of GPG Keychain Access.

    Let us know your findings.

    All the best,

    Please consider a donation. We do all this in our spare time.

  2. 2 Posted by Eric Stobbart on 12 Aug, 2012 04:27 PM

    Eric Stobbart's Avatar

    I was able to import without updating.
    Looked like it was a problem with file corruption in the mail program I use.
    I had someone send me the key without using ms outlook and it worked fine.

    Hopefully this post will help others with the same problem.

    Solution: zip the key before sending it as an attachment.

    Thanks Steve.


  3. Support Staff 3 Posted by Steve on 12 Aug, 2012 04:31 PM

    Steve's Avatar

    Hehe, MS Outlook. Always good for some trouble. ;)

    Glad you were able to solve this now.

    Closing. Have a nice day!


  4. Steve closed this discussion on 12 Aug, 2012 04:31 PM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts


? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac