No inline option?

Bill's Avatar


28 Jul, 2012 04:16 AM

Is there no option for sending an email encrypted inline anymore?

  1. 1 Posted by Bill on 28 Jul, 2012 04:17 AM

    Bill's Avatar

    Sorry, forgot to mention I'm using OSX 10.7.4 and GPGTools 2012.03.18.

  2. Support Staff 2 Posted by Steve on 28 Jul, 2012 07:57 AM

    Steve's Avatar

    Hey Bill,

    encrypted inline is actually not a standard and causes trouble all over the place. That's why we decided to default to the documented standard PGP/MIME.

    Do you rely on inline? Out of curiosity - what's your use case for inline?

    There's a terminal command we can send you, if you want to activate inline. We might add it as an option on a later point in time.

    Let us know, if you need that command.

    All the best,

  3. 3 Posted by Bill on 28 Jul, 2012 01:39 PM

    Bill's Avatar

    No, I suppose I dont rely on it. I guess I just got used to using it, and I liked that the emails did not have attachments. Not to mention the 'looks cool' factor.

    If its that problematic then I can live without it...

  4. Support Staff 4 Posted by Steve on 28 Jul, 2012 02:12 PM

    Steve's Avatar

    Not problematic at all... I'm just trying to understand where the benefits are.

    Are you using Apple with GPGMail? Which version of mail are you on? You should not see any attachments at all. That's exactly why there is GPGMail. Depending on your settings it should automatically decrypt any incoming mail (or ask for your passphrase during that process).

    We think it looks even cooler, if you don't see too much mumbojumbo and can jump right on the content. :)


  5. 5 Posted by Bill on 28 Jul, 2012 09:04 PM

    Bill's Avatar

    I meant problematic as in '...causes trouble all over the place.' Personally I like all the scrambled text in an inline email, but thats a just personal thing I guess.

    I'm on Mail Version 5.2 (1278). Here is what I see, is this what is expected?

  6. Support Staff 6 Posted by Steve on 28 Jul, 2012 09:26 PM

    Steve's Avatar

    OK, this is not what things should like. You are running an "old" alpha version of GPGMail 2.0. Could you please run the latest nightly GPGTools installer from here: and see if that improves the situation?

    You certainly have the needed sec key in GPG Keychain Access to encrypt that message?

    Best, steve

  7. 7 Posted by Bill on 28 Jul, 2012 09:47 PM

    Bill's Avatar

    Ok, updated with the nightly build. Here is what I get now.
    There are still attachments though. If I choose not to decrypt I get the same result with the 2 attachments in the email as the previous jpg.

  8. Support Staff 8 Posted by Steve on 28 Jul, 2012 10:05 PM

    Steve's Avatar

    How do you mean "not to choose to decrypt"? If you don't enter your passphrase when asked for?

    That is of course expected. But if you don't want to encrypt you don't want to see the message. Then I'm not sure I understand why the attachements bother you.

    Should you decide to store your passphrase in the mac keychain (or for a certain amount of time) messages will auto-decrypt when selected.

  9. 9 Posted by Bill on 28 Jul, 2012 10:17 PM

    Bill's Avatar

    They dont bother me per se, its just above you said 'you shouldn't see any attachments at all'. I was just saying that if I choose not to decrypt a message when asked for my passphrase I see 2 attachments. If that is expected behavior then ok, no issues here.

    Anyhoo, my original question about no inline option is answered. I understand it GPGTools is following the PGP/MIME standard.


  10. Support Staff 10 Posted by Steve on 29 Jul, 2012 07:36 AM

    Steve's Avatar

    You are perfectly right with your last comment. I have my passphrase in the mac keychain, so I don't see attachments. But that's just me. Think we got this solved. :)


  11. Steve closed this discussion on 29 Jul, 2012 07:36 AM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts


? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac