GPG keychain access 1.0b7 Sending key failed

andrew's Avatar


13 Jul, 2012 11:51 AM


Looks like I'm having the same problem as a few other people with Mac GPG, I've got as far as generating a key, but I'm unable to send it to the keyserver. Updating to the nightly did not fix this, but it did give me a more detailed error message:

Send keys failed!
Code = 0

Error text:
gpg: sending key 0D7A8E1D to hkp server
gpg: keyserver internal error
gpg: keyserver send failed: Keyserver error

Any advice on how to proceed would be appreciated.

  1. 1 Posted by Andrew on 13 Jul, 2012 09:49 PM

    Andrew's Avatar

    Update... I tried again a few hours later, and it worked. I'm guessing it was a connectivity problem or (as he error said) and internal keyserver problem?

  2. Support Staff 2 Posted by Steve on 18 Jul, 2012 04:41 PM

    Steve's Avatar

    Hey Andrew, thanks for the feedback. Key servers can be flakey. If you encounter any issues that are key server related, it might help, to simply change the key server and try some other addresses.

    This can be done either in GPGPreferences or in GPG Keychain Access (cmd , to go to the settings).

    We also have a wiki so should you encounter a broken key server feel free to update the wiki. On the long run, we can then identify the bad boys and remove those from the default key server list.

    Cheers and all the best,

  3. Support Staff 3 Posted by Steve on 15 Aug, 2012 08:45 AM

    Steve's Avatar

    No further user feedback. Closing.

    @Andrew: Should your problem persist, feel free to re-open this discussion any time.

    All the best,

    Please consider a donation. We do all this in our spare time.

  4. Steve closed this discussion on 15 Aug, 2012 08:45 AM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts


? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac