No subject

Kerrigan29a's Avatar


09 Jul, 2012 07:36 PM


  • Software name and version: GPGMail 2.0a30
  • OS X version: 10.7.3
  • GPGTools Installer date: 20120318


I use to receive emails encrypted with Mozilla Thunderbird Enigmail. The problem is that the 'Content-type' field has the value 'text/html; charset=ISO-8859-1' instead of the typical 'multipart/encrypted, [...] ; protocol="application/pgp-encrypted";'. Due to this, GPGMail (I think so) can't realize that it's an encrypted mail and don't decrypt it automatically.
So I select the text and try to use the decrypt service (that I have enabled) and nothing happens (Mail app lose the focus of the main window, I don't know why). So each time I want to to read this emails I have to use the command-line tool.

  1. Support Staff 1 Posted by Luke Le on 09 Jul, 2012 07:41 PM

    Luke Le's Avatar

    Hi Kerrigan,

    could you please install The nightly Version of GPGMail from

    This issue should already be fixed.
    Please let us know if the nightly helped.

  2. 2 Posted by Kerrigan29a on 09 Jul, 2012 07:49 PM

    Kerrigan29a's Avatar

    This one?
    GPGMail_Experimental-trunk-108914.dmg from 04-Jun-2012

    Installed and same problem.

  3. Support Staff 3 Posted by Luke Le on 09 Jul, 2012 08:00 PM

    Luke Le's Avatar

    Uh sorry, we've recently lost some apache config files and nightly is a bit of a mess currently.

    The correct version would be but the one you've installed should have the fix already.

    Could you please send an example message to lukele at after you've removed any private and confidential information.


  4. 4 Posted by Kerrigan29a on 09 Jul, 2012 08:18 PM

    Kerrigan29a's Avatar


  5. Support Staff 5 Posted by Luke Le on 09 Jul, 2012 09:12 PM

    Luke Le's Avatar

    Ok, if there's only a Text/html and no text/plain part we can't do much about it unfortunately since it's very hard to extract only the pgp message from the html. Even if the extraction worked for one client, it would most certainly fail for others since most clients use different HTML formatting.
    Clear signed messages wouldn't work at all.

    The sender should be persuaded to use PGP/MIME instead of inline PGP, which is possible to configure in Enigmail but not enabled by default.

    Sorry for the bad news

  6. 6 Posted by Kerrigan29a on 09 Jul, 2012 10:28 PM

    Kerrigan29a's Avatar

    Yes, that's why then, I've tried to select manually the text and use the decypher service, but it did nothing but loose the focus of the window.

  7. Support Staff 7 Posted by Steve on 10 Jul, 2012 10:24 AM

    Steve's Avatar

    Convince the sender to use PGP/MIME if possible. That should resolve this problem.

  8. Support Staff 8 Posted by Luke Le on 10 Jul, 2012 11:38 AM

    Luke Le's Avatar

    GPGServices should allow to decrypt this type of message as a last resort though.

    Could you add ticket for that Steve?

  9. Support Staff 9 Posted by Steve on 25 Jul, 2012 11:11 AM

    Steve's Avatar

    No further user feedback. Closing.

    @Kerrigan29a: Should your problem persist, feel free to re-open this discussion any time.

    All the best,

    Please consider a donation. We do all this in our spare time.

  10. Steve closed this discussion on 25 Jul, 2012 11:11 AM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts


? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac