HELP! Can't encrypt from within Text Edit (or any other)

Bram's Avatar


30 Jun, 2012 12:12 AM

I've watched the demos and to encrypt some text all it seems I need to do is select it and choose Encrypt from the Services menu.

Problem is, GPG Encrypt (or any other options) don't appear in the services menu in any of my text applications.

It works with files... but not with text.

Any ideas?


  1. Support Staff 1 Posted by Luke Le on 30 Jun, 2012 12:18 AM

    Luke Le's Avatar

    Hi Bram,

    unfortunately OS X services are a fickle beast, that's also why GPGServices doesn't always work.
    Please try to install the nightly version from to see if that fixes your problem.

    Also you might consider restarting your mac in order for the service to be correctly loaded. It shouldn't be necessary but it can't hurt either.

    Hope that helps.

  2. 2 Posted by Bram on 30 Jun, 2012 12:52 AM

    Bram's Avatar

    Thanks Luke, but that didn't work. I've had nothing but hours of aggravation from GPG Mac, I gave up months ago, and am about to again.

    Thanks to all who give of their time for this project, but if it doesn't work, what's the point?


  3. Support Staff 3 Posted by Luke Le on 30 Jun, 2012 12:58 AM

    Luke Le's Avatar

    Hi Bram,

    I completely understand your frustration, but you're among few cases where it doesn't work.
    For most of our users it does, and very well at that.
    Software is very unpredictable in that way. Thousands of users could have no problem at all, and some users run into a bug which causes it to not work at all.
    Very frustrating for us as well.

    If you want to I'd be glad to debug this issue further with you, but it's understandable if you don't wanna waste anymore time on it.

  4. Support Staff 4 Posted by Steve on 30 Jun, 2012 07:34 AM

    Steve's Avatar

    Hey Bram, did you activate the GPGServices in Systems Settings > Keyboard > Services in the first place?

    I can understand your frustration but let's try to get you sorted. Which operating system are you on?

    All the best,

  5. 5 Posted by Bram on 30 Jun, 2012 04:20 PM

    Bram's Avatar

    Thanks Luke and Steve, the helpful, friendly, support here helps offset my frustration.

    I just got Symantic's version running fine as a demo, but I'd prefer not to have to pay $159 for the occasional encrypted message.

    I'm on a Mac Book Pro, OS X 10.7.4 and yes I've activated GPG services in System settings. They just don't show up in my applications. (PGP does)

    Everything seems to be working fine (mail, encrypting text and graphic files) except for being able to encrypt text in Text Edit, Pages or Word.

    Any suggestions would be appreciated.

  6. 6 Posted by cfraire on 30 Jun, 2012 07:26 PM

    cfraire's Avatar


    One thing you might check: on Lion, there are two sections of Services items to manage in Preferences:

    Keyboard > Services > Keyboard Shortcuts > Files & Folders > OpenPGP
    Keyboard > Services > Keyboard Shortcuts > Text > OpenPGP

    Please confirm that items such as "OpenPGP: Encrypt Selection" and "OpenPGP: Decrypt Selection" are checked under "Text".

  7. 7 Posted by Bram on 30 Jun, 2012 08:05 PM

    Bram's Avatar

    cfraire, that appears to have solved it. There are still some conflicts with the Symantic version of PGP that I installed, but I have reason to believe this might do it once I get rid of them. Such a simple thing, but something I overlooked.


  8. Support Staff 8 Posted by Steve on 04 Jul, 2012 03:31 PM

    Steve's Avatar

    Hey Bram, since this is an often asked question, I have created a Knowledge Base article about this.

    It would be great, if you could read it and let me know if I need to correct things or if it makes sense as it is.

    All the best :)

    Please consider a donation. We do all this in our spare time.

  9. 9 Posted by Bram on 04 Jul, 2012 04:22 PM

    Bram's Avatar

    I'd be happy to look it over, do you have a link?

  10. Support Staff 10 Posted by Steve on 04 Jul, 2012 04:27 PM

    Steve's Avatar
  11. Support Staff 11 Posted by Steve on 22 Jul, 2012 06:15 PM

    Steve's Avatar

    No further user feedback. Closing.

    @Bram: Should your problem persist, feel free to re-open this discussion any time.

    All the best,

    Please consider a donation. We do all this in our spare time.

  12. Steve closed this discussion on 22 Jul, 2012 06:15 PM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts


? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac