cannot decrypt emails that are not also signed

Jeff's Avatar

Jeff

28 Jun, 2012 10:10 PM

Environment:

  • Software name and version: GPGMail 1.3.3 and GPG Keychain Access 1.0b3
  • OS X version: 10.6.8
  • GPGTools Installer date: 3/22/12

OpenPGP emails received, press Decrypt button, message appears "Message has been encrypted but not signed. Its authenticity cannot be proved". Public key in GPG Keychain is verified/signed/trusted.

Mail:Preferences:GPGMail:Viewing:Authenticate automatically is unchecked

We should be able to decrypt emails that are not signed if we are using trusted keys (i.e. keys in GPG Keychain that have been signed, thus marking them as trusted.

I cannot use this product. Of course, I can cut/paste into a text file that decrypts fine with GPGTools, but doesn't that defeat the purpose of having a mail add-in???

What do you expect to see? What do you see instead?

  • I want to see decrypted content
  • Instead stupid message that doesn't allow me to decrypt unless the message is signed (if you are going to enforce this then why are there options in Preferences? Or what am I doing wrong here?

Note that a signed/trusted public key is the equivalent of signing the message.

Provide any additional information, link a screenshot and debug output if possible.

  • Screenshot: see attachment
  • Debug output from /Applications/Utilities/Console.app: ...

First aid

  • Have you already tried running the latest nightly of the GPGTool Installer? Do you support 10.6.8 on your nightly?
  1. Support Staff 1 Posted by Luke Le on 28 Jun, 2012 11:25 PM

    Luke Le's Avatar

    Hi Jeff,

    unfortunately due to all of Mail.app's changes for Lion we had to rewrite a lot of parts of GPGMail and thus decided to write it from scratch. That also meant that we couldn't support Snow Leopard any further. We're a very small team of 4-5 active people which means we have to focus on certain things and especially with GPGMail which is still a hack (since Apple tolerates but still doesn't officially support plugins) we've had to focus on the newer versions only.

    Long story short, we can't support Snow Leopard and the version will remain as it is unless some willing developer is found which fixes old problems.

    The new version of GPGMail for Lion doesn't have any of these problems and the integration into Mail.app's interface is much less obtrusive.

    So if you have any chance to upgrade your machine to Lion, that's your best choice, otherwise I'm really sorry to say, we can't help you here.

  2. 2 Posted by Jeff Bronte on 29 Jun, 2012 04:11 PM

    Jeff Bronte's Avatar

    Thanks Luke, that's what I figured...If I wasn't so busy I'd jump in and
    fix it, probably can't be that hard to skip over the required signing
    verification.
     

    Let me try the Symantec 'proxy' client. (I wanted to avoid that as well as
    the upgrade to Lion if possible).

    If I end up fixing it I'll send you a patch.

    Jeff

  3. Support Staff 3 Posted by Steve on 29 Jun, 2012 10:58 PM

    Steve's Avatar

    Hey Jeff,

    great stuff. Let us know how it goes and if you can fix it.

    Also sorry we can't work on old versions. That is simply due to an insane small team size of people involved with the project. So we try to concentrate on the most critical stuff first.

    All the best,
    steve

  4. Support Staff 4 Posted by Steve on 22 Jul, 2012 06:14 PM

    Steve's Avatar

    Jeff, have you found out anything new or can I close this discussion?

  5. 5 Posted by Jeff Bronte on 22 Jul, 2012 07:24 PM

    Jeff Bronte's Avatar

    Hi Steve,

      Thank you for the followup. I think it's fair not to support older OSs,
    so you can close this. I can tell you that Symantec PGP email for Mac is
    junk and IMO unusable to me. I'll wait to upgrade my OS before trying
    GPGTools again for email.

    Jeff

  6. Support Staff 6 Posted by Steve on 22 Jul, 2012 07:31 PM

    Steve's Avatar

    Hm, more fiddling around with GPGMail 1.3.3 under 10.6 might be worth a try. Many people have been using it without problems for quite some time. Sorry, that you are seeing this problem. You still might wanna try the nightly installer (which e.g. contains the latest GPG Keychain Access and some other fixes that might help solve your problem). Find that here: http://nightly.gpgtools.org/

    ALl the best, steve

  7. Steve closed this discussion on 15 Aug, 2012 08:48 AM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac